Skip to content

Instantly share code, notes, and snippets.

Avatar

Sarah Federman sarahbethfederman

View GitHub Profile
View package.json
dependencies: {
"myPackageThatDependsOnReact": "^1.0.0",
"react": "16.0.0"
}
@sarahbethfederman
sarahbethfederman / package.json
Last active Sep 21, 2020
yarn-resolution-hack
View package.json
"resolutions": {
"foo": "1.4.9"
}
View package.json
"resolutions": {
"foo": "1.4.9"
}
@sarahbethfederman
sarahbethfederman / package.json
Last active Sep 21, 2020
yarn-resolutions-1
View package.json
"resolutions": {
"babel/foo": "1.4.9",
}
@sarahbethfederman
sarahbethfederman / yarn.lock
Last active Sep 21, 2020
yarn-lock-dedupe
View yarn.lock
"pkg-a@1.1.0"
version "1.1.0"
dependencies:
pkg-b "^2.1.0"
"pkg-c@1.0.0"
version "1.0.0"
dependencies:
pkg-b "^2.0.0"
@sarahbethfederman
sarahbethfederman / yarn.lock
Last active Sep 21, 2020
yarn-lock-update-2
View yarn.lock
"pkg-a@1.1.0"
version "1.1.0"
dependencies:
pkg-b "^2.1.0"
"pkg-c@1.0.0"
version "1.0.0"
dependencies:
pkg-b "^2.0.0"
@sarahbethfederman
sarahbethfederman / yarn.lock
Last active Sep 21, 2020
yarn-lock-update-1
View yarn.lock
"pkg-a@1.1.0"
version "1.1.0"
dependencies:
pkg-b "^2.1.0"
"pkg-c@1.0.0"
version "1.0.0"
dependencies:
pkg-b "^2.0.0"
@sarahbethfederman
sarahbethfederman / yarn.lock
Last active Sep 21, 2020
yarn-lock-install
View yarn.lock
"pkg-a@1.0.0"
version "1.0.0"
dependencies:
pkg-b "^2.0.0"
"pkg-c@1.0.0"
version "1.0.0"
dependencies:
pkg-b "^2.0.0"
View yarn.lock
"pkg-a@<VERSION_RANGE>"
version: version of pkg-a that we resolve to
dependencies:
pkg-b: the range that is specified in pkg-a's package.json
"pkg-b@<VERSION_RANGE>"
version: the version that packages depending on pkg-b@<VERSION-RANGE> get
"pkg-b@<INCOMPATIBLE_VERSION_RANGE>"
View yarn.lock
"pkg-a@<VERSION_RANGE>"
version: version of pkg-a that we resolve to
dependencies:
pkg-b: the range that is specified in pkg-a's package.json
"pkg-b@<VERSION_RANGE>, pkg-b@<COMPATIBLE_VERSION_RANGE>"
version: the version that packages depending on pkg-b get
You can’t perform that action at this time.