Skip to content

Instantly share code, notes, and snippets.

@sckott
Last active Oct 12, 2015
Embed
What would you like to do?
anybody else getting this?

On win-builder for v3.2.1 I'm getting

* using log directory 'd:/RCompile/CRANguest/R-release/rcrossref.Rcheck'
* using R version 3.2.1 (2015-06-18)
* using platform: x86_64-w64-mingw32 (64-bit)
* using session charset: ISO8859-1
* checking for file 'rcrossref/DESCRIPTION' ... OK
* this is package 'rcrossref' version '0.3.3.9300'
* checking CRAN incoming feasibility ... NOTE
Maintainer: 'Scott Chamberlain <myrmecocystus@gmail.com>'

License components with restrictions and base license permitting such:
  MIT + file LICENSE
File 'LICENSE':
  YEAR: 2015
  COPYRIGHT HOLDER: Scott Chamberlain

Possibly mis-spelled words in DESCRIPTION:
  APIs (2:39, 3:45)
* checking package namespace information ... OK
* checking package dependencies ... ERROR
  No repository set, so cyclic dependency check skipped

Package required and available but unsuitable version: 'httr'

See section 'The DESCRIPTION file' in the 'Writing R Extensions'
manual.
* DONE
Status: 1 ERROR, 1 NOTE

WAT? cran has v1 of httr http://cran.r-project.org/web/packages/httr/

line in my DESCRIPTION file https://github.com/ropensci/rcrossref/blob/master/DESCRIPTION#L24

@Robinlovelace
Copy link

Robinlovelace commented Oct 12, 2015

Hi @sckott I'm getting almost exactly the same message on my stplanr check on Windows but not on Linux it seems...

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment