public
Created

swiften-git version 20130408 from AUR work with spectrum2-git

  • Download Gist
PKGBUILD
Shell
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40
# Maintainer: ntkoopman ???
# Contributor: Shizeeg Unadequatov <shizeeque@gmail.com>
 
pkgname=swiften-git
pkgver=20130408
pkgrel=1
pkgdesc="XMPP Client Library"
arch=('i686' 'x86_64')
url="http://swift.im/"
license=('GPL3')
depends=('libidn' 'avahi' 'libxss' 'expat' 'openssl' 'boost-libs' 'libxml2' 'libidn' 'qt4')
makedepends=('git' 'scons' 'boost')
provides=('swiften')
conflicts=('swiften')
 
source=('swift::git://swift.im/swift')
md5sums=('SKIP')
_gitname='swift'
_commit=7d9c895ba6f1cdb56925a5313b989ecb2c5217fa
 
#pkgver() {
# cd "$_gitname"
# echo "$(git log -1 --date=short | grep Date | sed 's|[^0-9]||g')"
#}
 
build() {
cd "$_gitname"
# last known to work with spectrum2-git
git reset --hard $_commit
scons V=1 swiften_dll=1 Swiften SWIFTEN_INSTALLDIR=${pkgdir}/usr force-configure=1
}
 
package() {
cd "$_gitname"
scons V=1 swiften_dll=1 Swiften SWIFTEN_INSTALLDIR=${pkgdir}/usr ${pkgdir}/usr
 
find "$pkgdir" -type d -name .git -exec rm -r '{}' +
}
 
# vim:set ts=2 sw=2 et:

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.