public
Created

Terminal emulator for directfb. Fixed PKGBUILD.

  • Download Gist
PKGBUILD
Shell
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42
# Maintainer: Jesse Jaara <gmail.com: jesse.jaara>
# Contributor: Shizeeg Unadequatov <shizeeque@gmail.com>
 
pkgname=dfbterm-git
pkgver=20121217
pkgrel=1
pkgdesc="Terminal emulator for directfb. Git version"
arch=('i686' 'x86_64')
url="http://www.directfb.org"
license=('LGPL')
depends=('lite-git' 'directfb')
makedepends=('git' 'automake<1.13' 'autoconf' 'libtool' 'pkg-config')
provides=('dfbterm')
conflicts=('dfbterm')
 
source=('dfbterm::git://git.directfb.org/git/directfb/programs/DFBTerm.git')
md5sums=('SKIP')
_gitname="dfbterm"
 
pkgver() {
cd "${_gitname}"
# generate version from git commit count
# echo "$(git rev-list --count makepkg).$(git rev-parse --short makepkg)"
 
# also you can generate version from tip date
echo $(git log -1 --date=short | grep Date | sed 's|[^0-9]||g')
}
 
build() {
cd "${_gitname}"
./autogen.sh --prefix=/usr
./configure
make
}
 
package() {
cd "${_gitname}"
make DESTDIR="${pkgdir}" install
 
find "${pkgdir}" -type d -name .git -exec rm -r '{}' +
}
#vim: set ts=2 sw=2 et:

Seems like it won't build with automake >= 1.13.

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.