Skip to content

Instantly share code, notes, and snippets.

@sime sime/gist:5079460
Last active Dec 14, 2015

Embed
What would you like to do?
Activemerchant requires older version of builder, which conflicts which activemodel?
$ ruby main.rb
/opt/local/lib/ruby1.9/1.9.1/rubygems/specification.rb:1637:in `raise_if_conflicts': Unable to activate activemodel-3.2.12, because builder-3.2.0 conflicts with builder (~> 3.0.0) (Gem::LoadError)
from /opt/local/lib/ruby1.9/1.9.1/rubygems/specification.rb:746:in `activate'
from /opt/local/lib/ruby1.9/1.9.1/rubygems/specification.rb:780:in `block in activate_dependencies'
from /opt/local/lib/ruby1.9/1.9.1/rubygems/specification.rb:766:in `each'
from /opt/local/lib/ruby1.9/1.9.1/rubygems/specification.rb:766:in `activate_dependencies'
from /opt/local/lib/ruby1.9/1.9.1/rubygems/specification.rb:750:in `activate'
from /opt/local/lib/ruby1.9/1.9.1/rubygems/custom_require.rb:51:in `block in require'
from /opt/local/lib/ruby1.9/1.9.1/rubygems/custom_require.rb:50:in `each'
from /opt/local/lib/ruby1.9/1.9.1/rubygems/custom_require.rb:50:in `require'
from /opt/local/lib/ruby1.9/gems/1.9.1/gems/sinatra-activerecord-1.2.2/lib/sinatra/activerecord.rb:2:in `<top (required)>'
from /opt/local/lib/ruby1.9/1.9.1/rubygems/custom_require.rb:60:in `require'
from /opt/local/lib/ruby1.9/1.9.1/rubygems/custom_require.rb:60:in `rescue in require'
from /opt/local/lib/ruby1.9/1.9.1/rubygems/custom_require.rb:35:in `require'
from main.rb:9:in `<main>'
GEM
remote: http://rubygems.org/
specs:
active_utils (1.0.5)
activesupport (>= 2.3.11)
i18n
activemerchant (1.31.1)
active_utils (>= 1.0.2)
activesupport (>= 2.3.14)
builder (>= 2.0.0) # Buidler 1.
i18n
json (>= 1.5.1)
money
nokogiri
activemodel (3.2.12)
activesupport (= 3.2.12)
builder (~> 3.0.0) # Builder 2.
activerecord (3.2.12)
activemodel (= 3.2.12)
activesupport (= 3.2.12)
arel (~> 3.0.2)
tzinfo (~> 0.3.29)
activesupport (3.2.12)
i18n (~> 0.6)
multi_json (~> 1.0)
arel (3.0.2)
builder (3.0.4) # Builder 3.
excon (0.16.10)
i18n (0.6.4)
json (1.7.7)
mandrill-api (1.0.16)
excon (~> 0.16.0)
json (~> 1.7.7)
money (5.1.1)
i18n (~> 0.6.0)
multi_json (1.6.1)
nokogiri (1.5.6)
rack (1.5.2)
rack-flash3 (1.0.3)
rack
rack
rack-protection (1.4.0)
rack
rake (10.0.3)
sinatra (1.3.5)
rack (~> 1.4)
rack-protection (~> 1.3)
tilt (~> 1.3, >= 1.3.3)
sinatra-activerecord (1.2.2)
activerecord (~> 3.0)
sinatra (~> 1.0)
sqlite3 (1.3.7)
tilt (1.3.4)
tzinfo (0.3.36)
validatable (1.6.7)
PLATFORMS
ruby
DEPENDENCIES
activemerchant
activerecord
activesupport
mandrill-api
rack-flash3
rake
sinatra
sinatra-activerecord
sqlite3
tzinfo
validatable
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.