Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Reolink RLC-810A Homebridge 4K Configuration
@avidnumberer
Copy link

I have the exact same configuration but homebridge fails to grab the snapshot for the still image. Have you ran into any issues like that?

[11/6/2022, 3:53:47 PM] [Camera FFmpeg] [Living Room] Failed to fetch snapshot.
[Living Room] Snapshot request handler provided empty image buffer!
[11/6/2022, 3:53:58 PM] [Camera FFmpeg] [Living Room] Failed to fetch snapshot.
[Living Room] Snapshot request handler provided empty image buffer!

@soxrok2212
Copy link
Author

soxrok2212 commented Nov 6, 2022

I have the exact same configuration but homebridge fails to grab the snapshot for the still image. Have you ran into any issues like that?

[11/6/2022, 3:53:47 PM] [Camera FFmpeg] [Living Room] Failed to fetch snapshot. [Living Room] Snapshot request handler provided empty image buffer! [11/6/2022, 3:53:58 PM] [Camera FFmpeg] [Living Room] Failed to fetch snapshot. [Living Room] Snapshot request handler provided empty image buffer!

Try changing the channel ID. It starts with 0 and increments by 1. I've just added some details if using an NVR.

@chrisloftus
Copy link

chrisloftus commented Dec 21, 2022

@soxrok2212 I think the URL has changed. When I perform a Snapshot in the camera admin panel the URL is like this:

https://192.168.0.43/cgi-bin/api.cgi?&token=<token>&encrypt=<encrypted>

The encrypted seems to change each time.

EDIT: If I remove the stillImageSource from the config it seems to work. :)

@avidnumberer
Copy link

I managed to get mine working with the following:

"stillImageSource": "-rtsp_transport tcp -i rtsp://user:password@0.0.0.0:554/h264Preview_01_main -vframes 1 -r 1",

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment