Skip to content

Instantly share code, notes, and snippets.

@speters33w
Last active April 5, 2022 20:38
Show Gist options
  • Save speters33w/538828d352fc474626a533681413e076 to your computer and use it in GitHub Desktop.
Save speters33w/538828d352fc474626a533681413e076 to your computer and use it in GitHub Desktop.
Mockup for Hacker Rank Java Loops II Challenge
/*
We use the integers a, b, and n to create the following series:
(a + 2⁰ · b),(a + 2⁰ · b + 2¹ · b),...,(a + 2⁰ · b + 2¹ · b +...+2⁽ⁿ⁻¹⁾ · b)
You are given q queries in the form of a, b, and n. For each query, print the series corresponding to the given a, b, and n values as a single line of n space-separated integers.
Input Format
The first line contains an integer, q, denoting the number of queries.
Each line i of the q subsequent lines contains three space-separated integers describing the respective a, b, and n values for that query.
Constraints
• 0 ≤ q ≤ 500
• 0 ≤ a,b ≤ 50
• 1 ≤ n ≤ 15
Output Format
For each query, print the corresponding series on a new line. Each series must be printed in order as a single line of
space-separated integers.
Sample Input
2
0 2 10
5 3 5
Sample Output
2 6 14 30 62 126 254 510 1022 2046
8 14 26 50 98
*/
import java.util.Scanner;
public class JavaLoopsII {
public static void main(String [] args) {
Scanner in = new Scanner(System.in);
int q=in.nextInt();
for(int i=0;i<q;i++){
int a = in.nextInt();
int b = in.nextInt();
int n = in.nextInt();
int num = n;
int pow = 0;
while (n>0) {
if (pow == 0)
System.out.print("("
+ a + " + 2^"
+ pow + " * " + b
+ ")");
if ((pow >= 1)
&& (n > 0))
System.out.print("("
+ a + " + 2^"+ pow + " * "
+ b + ")");
pow++;n--;
if(n >= 1)System.out.print(" + ");
if(n == 0) System.out.print("\n");
}
}
in.close();
}
}
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment