Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
ssbarnea@m1: ~/c/a/ansible devel ⚡
$ which -a ansible
ansible not found
FAIL: 1
ssbarnea@m1: ~/c/a/ansible devel ⚡
$ pip install -e .
Obtaining file:///Users/ssbarnea/c/a/ansible
Installing build dependencies ... done
Checking if build backend supports build_editable ... done
Getting requirements to build editable ... done
Preparing editable metadata (pyproject.toml) ... done
Requirement already satisfied: jinja2>=3.0.0 in /Users/ssbarnea/.pyenv/versions/3.11-dev/lib/python3.11/site-packages (from ansible-core==2.15.0.dev0) (3.1.2)
Requirement already satisfied: PyYAML>=5.1 in /Users/ssbarnea/.local/lib/python3.11/site-packages (from ansible-core==2.15.0.dev0) (6.0)
Requirement already satisfied: cryptography in /Users/ssbarnea/.pyenv/versions/3.11-dev/lib/python3.11/site-packages (from ansible-core==2.15.0.dev0) (37.0.4)
Requirement already satisfied: packaging in /Users/ssbarnea/.pyenv/versions/3.11-dev/lib/python3.11/site-packages (from ansible-core==2.15.0.dev0) (20.9)
Requirement already satisfied: resolvelib<0.9.0,>=0.5.3 in /Users/ssbarnea/.pyenv/versions/3.11-dev/lib/python3.11/site-packages (from ansible-core==2.15.0.dev0) (0.8.1)
Requirement already satisfied: MarkupSafe>=2.0 in /Users/ssbarnea/.pyenv/versions/3.11-dev/lib/python3.11/site-packages (from jinja2>=3.0.0->ansible-core==2.15.0.dev0) (2.1.1)
Requirement already satisfied: cffi>=1.12 in /Users/ssbarnea/.pyenv/versions/3.11-dev/lib/python3.11/site-packages (from cryptography->ansible-core==2.15.0.dev0) (1.15.1)
Requirement already satisfied: pyparsing>=2.0.2 in /Users/ssbarnea/.pyenv/versions/3.11-dev/lib/python3.11/site-packages (from packaging->ansible-core==2.15.0.dev0) (3.0.9)
Requirement already satisfied: pycparser in /Users/ssbarnea/.pyenv/versions/3.11-dev/lib/python3.11/site-packages (from cffi>=1.12->cryptography->ansible-core==2.15.0.dev0) (2.21)
Building wheels for collected packages: ansible-core
Building editable for ansible-core (pyproject.toml) ... done
Created wheel for ansible-core: filename=ansible_core-2.15.0.dev0-0.editable-py3-none-any.whl size=18934 sha256=9fc2f6b5f1120e1fd32478eb62dada752e9a302f41a22e9e6f78493cdd9b0fbf
Stored in directory: /private/var/folders/32/1xrphgzd4xv777syxjtkpdw80000gn/T/pip-ephem-wheel-cache-gtwg3rdo/wheels/1e/00/5d/988773a5dbb5aa519b03996e25b3c7590be2111cbc3fe54a00
Successfully built ansible-core
Installing collected packages: ansible-core
ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
ansible-lint 6.8.5.dev1 requires ansible-compat>=2.2.1, but you have ansible-compat 2.2.1.dev6 which is incompatible.
Successfully installed ansible-core-2.15.0.dev0
ssbarnea@m1: ~/c/a/ansible devel ⚡
$ ansible --version
Traceback (most recent call last):
File "/Users/ssbarnea/.pyenv/versions/3.11-dev/bin/ansible", line 5, in <module>
from ansible.cli.adhoc import main
File "/Users/ssbarnea/c/a/ansible/lib/ansible/cli/adhoc.py", line 11, in <module>
from ansible.cli import CLI
ImportError: cannot import name 'CLI' from 'ansible.cli' (unknown location)
FAIL: 1
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment