public
Last active

python2-amqp PKGBUILD for version 1.0.13

  • Download Gist
PKGBUILD
Shell
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
# Maintainer: Xeross <contact@xeross.me>
# Contributor: Timothée Ravier <tim@siosm.fr>
 
pkgname=python2-amqp
pkgver=1.0.13
pkgrel=1
pkgdesc="Low-level AMQP client for Python (fork of amqplib)"
arch=('any')
url="https://github.com/celery/py-amqp/"
license=("LGPL")
depends=('python2>=2.6' 'setuptools')
source=(https://pypi.python.org/packages/source/a/amqp/amqp-${pkgver}.tar.gz)
sha256sums=('15fed1a2f0326f198a9d3d16ce1dc4296385d33859bd9f7c59705093fab8f53c')
 
prepare() {
cd amqp-${pkgver}
# replace /usr/bin/env python with python2
find . -name '*.py' -exec sed -i -e '1 s/python\s*$/python2/' {} \;
}
 
package() {
cd amqp-${pkgver}
python2 ./setup.py install --root="${pkgdir}" --prefix=/usr
}
 
# vim: ft=sh syn=sh

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.