Skip to content

Instantly share code, notes, and snippets.

@stahnma

stahnma/gist:578421

Created Sep 14, 2010
Embed
What would you like to do?
sudo rake test
(in /Library/Ruby/Gems/1.8/gems/rcov-0.9.9)
sdoc support not enabled:
#<Gem::LoadError: Could not find RubyGem sdoc (>= 0)
>
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby setup.rb config
---> bin
<--- bin
---> lib
---> lib/rcov
---> lib/rcov/formatters
<--- lib/rcov/formatters
---> lib/rcov/templates
<--- lib/rcov/templates
<--- lib/rcov
<--- lib
---> ext
---> ext/rcovrt
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby /Library/Ruby/Gems/1.8/gems/rcov-0.9.9/ext/rcovrt/extconf.rb
creating Makefile
---> ext/rcovrt/1.8
<--- ext/rcovrt/1.8
---> ext/rcovrt/1.9
<--- ext/rcovrt/1.9
<--- ext/rcovrt
<--- ext
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby setup.rb setup
---> bin
Skipping shebang rename
<--- bin
---> lib
---> lib/rcov
---> lib/rcov/formatters
<--- lib/rcov/formatters
---> lib/rcov/templates
<--- lib/rcov/templates
<--- lib/rcov
<--- lib
---> ext
---> ext/rcovrt
make
gcc -I. -I/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/universal-darwin10.0 -I/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/universal-darwin10.0 -I1.8/ -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -fno-common -arch i386 -arch x86_64 -g -Os -pipe -fno-common -DENABLE_DTRACE -fno-common -pipe -fno-common -c 1.8/callsite.c
gcc -I. -I/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/universal-darwin10.0 -I/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/universal-darwin10.0 -I1.8/ -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -fno-common -arch i386 -arch x86_64 -g -Os -pipe -fno-common -DENABLE_DTRACE -fno-common -pipe -fno-common -c 1.8/rcovrt.c
cc -arch i386 -arch x86_64 -pipe -bundle -undefined dynamic_lookup -o rcovrt.bundle callsite.o rcovrt.o -L. -L/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib -L. -arch i386 -arch x86_64 -lruby -lpthread -ldl
---> ext/rcovrt/1.8
<--- ext/rcovrt/1.8
---> ext/rcovrt/1.9
<--- ext/rcovrt/1.9
<--- ext/rcovrt
<--- ext
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby -I"lib:ext/rcovrt" "/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader.rb" "test/call_site_analyzer_test.rb" "test/code_coverage_analyzer_test.rb" "test/file_statistics_test.rb" "test/functional_test.rb"
Loaded suite /Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader
Started
............F.F..F...........................
Finished in 0.883806 seconds.
1) Failure:
test_differential_coverage_data(TestCodeCoverageAnalyzer) [./test/code_coverage_analyzer_test.rb:125]:
<[0, 1, 1, 1, 0]> expected but was
<[0, 1, 2, 0, 0]>.
2) Failure:
test_nested_analyzer_blocks(TestCodeCoverageAnalyzer) [./test/code_coverage_analyzer_test.rb:190]:
<[0, 221, 221, 221, 0]> expected but was
<[0, 221, 442, 0, 0]>.
3) Failure:
test_reset(TestCodeCoverageAnalyzer) [./test/code_coverage_analyzer_test.rb:209]:
<[0, 50, 50, 50, 0]> expected but was
<[0, 50, 100, 0, 0]>.
45 tests, 444 assertions, 3 failures, 0 errors
rake aborted!
Command failed with status (1): [/System/Library/Frameworks/Ruby.framework/...]
(See full trace by running task with --trace)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.