Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Gemfile for Jordan
# Gem File Standards
#
# Organization
# Alphabetize gems within their grouping
# Default to `require: false` to prevent increasing the rails load time
# Be conservative in which group to place a gem
# Comment on the same line when needed, ignore the column width limit
#
# Versioning
# peg to the current version using `~> x.y`
# This prevents accidental upgrades from one version to the next, but allows for
# major and minor patches, which should be non-breaking.
source "http://rubygems.org"
ruby "2.3.1"
gem "aasm", "~> 4.2"
gem "activerecord-import", "~> 0.10"
gem "activesupport-json_encoder", "~> 1.1"
gem "airbrake", "~> 4.0"
gem "ancestry", "~> 2.1"
gem "attribute_normalizer", "~> 1.2"
gem "auto_strip_attributes", "~> 2.1"
gem "autoprefixer-rails", "~> 6.3"
gem "awesome_print", "~> 1.1"
gem "aws-sdk", "~> 2"
gem "axlsx", "~> 1.3"
gem "bootstrap-datepicker-rails", "~> 1.4"
gem "browser", "~> 0.7"
gem "capistrano", "~> 2.15"
gem "capistrano-ext", "~> 1.2"
gem "capistrano-unicorn", "~> 0.2", require: false
gem "carmen", "~> 1.0"
gem "carmen-rails", "~> 1.0"
gem "childprocess", "~> 0.5"
gem "ckeditor", "~> 4.2"
gem "cocaine", "~> 0.5"
gem "coffee-rails", "~> 4.1"
gem "coffee-script", "~> 2.3"
gem "coffee-script-source", "~> 1.8" # latest is 1.9.0, but it causes a precompile error
gem "combine_pdf", "~> 1.0", require: false
gem "colorize", "~> 0.7"
gem "country_select", "~> 2.2.0"
gem "coverband", "~> 1.5"
gem "daemons", "~> 1.1"
gem "dalli", "~> 2.7"
gem "datejs-rails", "~> 2.0"
gem "days360", ">=0.3.2", require: false
gem "delayed_job", "~> 4.0"
gem "delayed_job_active_record", "~> 4.0"
gem "descriptive-statistics", "~> 2.1"
gem "devise", "~> 3.4.0"
gem "devise_security_extension", "~> 0.8"
gem "diffy", "~> 3.1", require: false
gem "distribution", "~> 0.7"
gem "diffy", "~> 3.1"
gem "font-awesome-rails", "~> 4.3"
gem "finance", "~> 1.1"
gem "forgery", "~> 0.5", require: false
gem "google-api-client", "~> 0.7", require: false
gem "google_drive", "~> 1.0", require: false
gem "hashie", "~> 2.1"
gem "heroku-api", "~> 0.3"
gem "highline", "~> 1.6"
gem "humanize", "~> 1.1" #numbers to words
gem "humanize_boolean", "~> 0.0"
gem "i18n", "~> 0.7"
gem "intercom-rails", "~> 0.3"
gem "jbuilder", "~> 1.5"
gem "jquery-fileupload-rails", "~> 0.4"
gem "jquery-rails", "~> 3.1"
gem "jquery-ui-rails", "~> 4.0"
gem "kaminari" , "~> 0.16"
gem "less-rails", "~> 2.7"
gem "libv8", "~> 3.16"
gem "liquid", "~> 3.0"
gem "log_it", "~> 0.4", github: "paulbaker3/log_it"
gem "mailchimp-api", "~> 2.0"
gem "money-rails", "~> 1.3"
gem "nested_form", "~> 0.3"
gem "net-ssh", "~> 2.9"
gem "newrelic_rpm", "~> 3.16", require: false
gem "nokogiri", "~> 1.6"
gem "nprogress-rails", "~> 0.1"
gem "oauth", "~> 0.4"
gem "omniauth", "~> 1.1"
gem "paper_trail", "~> 4.0.0.rc"
gem "paperclip", "~> 5.0.0.beta2"
gem "paranoia", "~> 2.0"
gem "pg", "0.18.1"
gem "pnotify-rails", "~> 1.2"
gem "possessive", "~> 1.0"
gem "postmark", "~> 1.0"
gem "postmark-rails", "~> 0.5"
gem "prawn", "1.0.0.rc2", require: false
gem "rack-cache", "~> 1.2"
gem "rails", "~> 4.2"
gem "rails-backbone", "~> 1.2.0"
gem "rails-html-sanitizer", "~> 1.0"
gem "rails-ujs", "~> 0.1"
gem "rake", "~> 11.0"
gem "ransack", "~> 1.6"
gem "raw_insert", "~> 0.2", github: "paulbaker3/raw_insert"
gem "rb-readline", "~> 0.5"
gem "render_anywhere", "~> 0.0", require: false
gem "react-rails", "~> 1.2"
gem "request_exception_handler", "~> 0.5"
gem "responders", "~> 2.1"
gem "retryable", "~> 2.0"
gem "roadie-rails", "~> 1.1"
gem "roo", "~> 2.4", github: "roo-rb/roo"
gem "roo-xls", "~> 1.0", github: "roo-rb/roo-xls"
gem "rubyzip", ">= 1.2.1"
gem "sass", "~> 3.4"
gem "sass-rails", "~> 5.0"
gem "select2-rails", "~> 3.5"
gem "selenium-webdriver", "~> 2.53"
gem "simplecov", "~> 0.13"
gem "soap2r", "~> 1.5"
gem "store_base_sti_class", "~> 0.4"
gem "slack-notifier", "~> 2.1"
gem "sprockets", "~> 3.6"
gem "sprockets-rails", "~> 3.0"
gem "stripe", "~> 1.31"
gem "table_print", "~> 1.5", require: false
gem "taps", "~> 0.3"
gem "therubyracer", "~> 0.12"
gem "tiny_tds", "~> 1.0", require: false
gem "turbolinks", "~> 2.5"
gem "twitter-bootstrap-rails", "~> 2.2", github: "stevebooks/twitter-bootstrap-rails" #path: "vendor/gems/twitter-bootstrap-rails"
gem "uglifier", "~> 1.3"
gem "unicorn", "~> 4.6"
gem "wicked", "~> 1.0"
gem "wicked_pdf", "~> 0.8"
gem "wkhtmltopdf-binary", "~> 0.9"
gem "zip-zip", "~> 0.3"
group :development do
gem "better_errors", "~> 1.1"
gem "binding_of_caller", "~> 0.7"
gem "capybara", "~> 2.7"
gem "capybara_minitest_spec", "~> 1.0"
gem "guard-minitest", "~> 2.3", require: false
gem "guard-zeus", "~> 2.0", require: false
gem "meta_request", "~> 0.2"
gem "rubocop", "~> 0.42", require: false
gem "thin", "~> 1.6"
gem "xray-rails", "~> 0.1", require: false
end
group :test do
gem "capybara-screenshot", "~> 1.0"
gem "capybara-email", "~> 2.4"
gem "chromedriver-helper", "~> 0.0"
gem "database_cleaner", "~> 1.4.1"
gem "codeclimate-test-reporter", "~> 0.4", require: nil
gem "konacha", "~> 4.0"
gem "m", "~> 1.3"
gem "minitest-focus", "~> 1.1"
gem "mocha", "~> 1.1", :require => false
gem "pdf-inspector", require: false
gem "shoulda-matchers", "~> 2.8"
gem "timecop", "~> 0.7"
end
group :development, :test do
gem "minitest", "~> 5.5", require: false
gem "minitest-autotest", "~> 1.0", require: false
gem "minitest-sprint", "~> 1.0", require: false
gem "minitest-bisect", "~> 1.0", require: false
gem "benchmark-ips", "~> 2.0", require: false
gem "ejs", "~> 1"
gem "pry", "~> 0.9", require: false
gem "pry-byebug", "~> 1.3", require: false
gem "shoulda-context", "~> 1.2"
end
group :production do
gem "skylight", "~> 0.10"
gem "yui-compressor", "~> 0.12"
end
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.