Skip to content

Instantly share code, notes, and snippets.

@tdsmith

tdsmith/flake8-requirements.rb Secret

Last active Jun 20, 2016
Embed
What would you like to do?
class Flake8Requirements < Formula
desc "Static analyzer for Python"
homepage "https://gitlab.com/pycqa/flake8"
url "https://files.pythonhosted.org/packages/60/4a/7b0ac4920af5673380b7079ba2f7580a8645790c7718881082c0d918b8b4/flake8-2.5.4.tar.gz"
sha256 "cc1e58179f6cf10524c7bfdd378f5536d0a61497688517791639a5ecc867492f"
def install
Language::Python.virtualenv(self, libexec/"venv") do |venv|
venv.pip_install! <<-EOS.undent
mccabe==0.4.0
pep8==1.7.0
pyflakes==1.0.0
EOS
venv.pip_install_and_link_scripts!(".", bin)
end
end
test do
system bin/"flake8", "-v"
end
end
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment