public
Last active

  • Download Gist
fragment.rb
Ruby
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
require 'rubygems'
require 'nokogiri'
 
doc = Nokogiri::HTML::Document.new
doc.encoding = 'UTF-8'
 
# We added a contextual fragment method for the 1.4.2 release. This *might*
# work in 1.4.1. If you want to mess with 1.4.2, build from my github, or
# grab one of our nightly builds:
#
# $ sudo gem install nokogiri -s http://tenderlovemaking.com/
#
# Also, libxml2 had a bug with encoding when handling UTF-8 fragments, so I
# suggest you also upgrade to libxml2 2.7.7.
#
# Hope that helps!
puts doc.fragment('<p>ö</p>')
output.txt
1
<p>ö</p>

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.