Skip to content

Instantly share code, notes, and snippets.

@tleite tleite/gist:3196410
Created Jul 29, 2012

Embed
What would you like to do?
Nodejitsu error when deploying
error: Error running command deploy
error: Nodejitsu Error (500): Internal Server Error
error: There was an error while attempting to deploy your application.
error:
error: NPM Install failed
error: NPM failed to install dependencies
error:
error: This type of error is usually a user error.
error: Error output from Haibu:
error:
error: npm WARN package.json LaunchTicker@0.0.1-2 No README.md file found!
error: npm http GET https://registry.npmjs.org/connect/1.8.5
error: npm http GET https://registry.npmjs.org/jade/0.20.0
error: npm http GET https://registry.npmjs.org/mongoose/2.4.8
error: npm http GET https://registry.npmjs.org/express/2.5.2
error: npm http GET https://registry.npmjs.org/socket.io/0.8.7
error: npm http 200 https://registry.npmjs.org/jade/0.20.0
error: npm http GET https://registry.npmjs.org/jade/-/jade-0.20.0.tgz
error: npm http 200 https://registry.npmjs.org/socket.io/0.8.7
error: npm http GET https://registry.npmjs.org/socket.io/-/socket.io-0.8.7.tgz
error: npm http 200 https://registry.npmjs.org/express/2.5.2
error: npm http GET https://registry.npmjs.org/express/-/express-2.5.2.tgz
error: npm http 200 https://registry.npmjs.org/connect/1.8.5
error: npm http 200 https://registry.npmjs.org/mongoose/2.4.8
error: npm http GET https://registry.npmjs.org/connect/-/connect-1.8.5.tgz
error: npm http GET https://registry.npmjs.org/mongoose/-/mongoose-2.4.8.tgz
error: npm http 200 https://registry.npmjs.org/jade/-/jade-0.20.0.tgz
error: npm http 200 https://registry.npmjs.org/socket.io/-/socket.io-0.8.7.tgz
error: npm http 200 https://registry.npmjs.org/express/-/express-2.5.2.tgz
error: npm http 200 https://registry.npmjs.org/connect/-/connect-1.8.5.tgz
error: npm http 200 https://registry.npmjs.org/mongoose/-/mongoose-2.4.8.tgz
error: npm WARN excluding symbolic link lib/index.js -> jade.js
error: npm WARN package.json connect@1.8.5 No README.md file found!
error: npm http GET https://registry.npmjs.org/mkdirp/0.0.7
error: npm http GET https://registry.npmjs.org/mime
error: npm http GET https://registry.npmjs.org/qs
error: npm http GET https://registry.npmjs.org/policyfile/0.0.4
error: npm http GET https://registry.npmjs.org/redis/0.6.7
error: npm http GET https://registry.npmjs.org/socket.io-client/0.8.7
error: npm http 200 https://registry.npmjs.org/mkdirp/0.0.7
error: npm http GET https://registry.npmjs.org/commander
error: npm http GET https://registry.npmjs.org/mkdirp
error: npm http GET https://registry.npmjs.org/mkdirp/-/mkdirp-0.0.7.tgz
error: npm http 200 https://registry.npmjs.org/mime
error: npm http 200 https://registry.npmjs.org/socket.io-client/0.8.7
error: npm http GET https://registry.npmjs.org/mime/-/mime-1.2.7.tgz
error: npm http GET https://registry.npmjs.org/socket.io-client/-/socket.io-client-0.8.7.tgz
error: npm http 200 https://registry.npmjs.org/mkdirp
error: npm http 200 https://registry.npmjs.org/policyfile/0.0.4
error: npm http 200 https://registry.npmjs.org/commander
error: npm http 200 https://registry.npmjs.org/qs
error: npm http 200 https://registry.npmjs.org/mime/-/mime-1.2.7.tgz
error: npm http 200 https://registry.npmjs.org/redis/0.6.7
error: npm http 200 https://registry.npmjs.org/socket.io-client/-/socket.io-client-0.8.7.tgz
error: npm http 200 https://registry.npmjs.org/mkdirp/-/mkdirp-0.0.7.tgz
error: npm http GET https://registry.npmjs.org/mkdirp/-/mkdirp-0.3.3.tgz
error: npm http GET https://registry.npmjs.org/commander/-/commander-0.2.1.tgz
error: npm http GET https://registry.npmjs.org/qs/-/qs-0.5.0.tgz
error: npm http GET https://registry.npmjs.org/policyfile/-/policyfile-0.0.4.tgz
error: npm http GET https://registry.npmjs.org/redis/-/redis-0.6.7.tgz
error: npm http 200 https://registry.npmjs.org/redis/-/redis-0.6.7.tgz
error: npm http 200 https://registry.npmjs.org/mkdirp/-/mkdirp-0.3.3.tgz
error: npm http 200 https://registry.npmjs.org/policyfile/-/policyfile-0.0.4.tgz
error: npm http 200 https://registry.npmjs.org/qs/-/qs-0.5.0.tgz
error: npm http 200 https://registry.npmjs.org/commander/-/commander-0.2.1.tgz
error: npm http GET https://registry.npmjs.org/formidable
error: npm http GET https://registry.npmjs.org/qs
error: npm http 200 https://registry.npmjs.org/formidable
error: npm http GET https://registry.npmjs.org/formidable/-/formidable-1.0.11.tgz
error: npm http 304 https://registry.npmjs.org/qs
error: npm http 200 https://registry.npmjs.org/formidable/-/formidable-1.0.11.tgz
error: npm http GET https://registry.npmjs.org/hooks/0.1.9
error: npm http GET https://registry.npmjs.org/mongodb/0.9.7-2-5
error: npm http GET https://registry.npmjs.org/colors/0.5.1
error: npm http 200 https://registry.npmjs.org/hooks/0.1.9
error: npm http 200 https://registry.npmjs.org/mongodb/0.9.7-2-5
error: npm http 200 https://registry.npmjs.org/colors/0.5.1
error: npm http GET https://registry.npmjs.org/hooks/-/hooks-0.1.9.tgz
error: npm http GET https://registry.npmjs.org/mongodb/-/mongodb-0.9.7-2-5.tgz
error: npm http GET https://registry.npmjs.org/colors/-/colors-0.5.1.tgz
error: npm WARN excluding symbolic link lib/socket.io-client.js -> io.js
error: npm http 200 https://registry.npmjs.org/hooks/-/hooks-0.1.9.tgz
error: npm http 200 https://registry.npmjs.org/mongodb/-/mongodb-0.9.7-2-5.tgz
error: npm http 200 https://registry.npmjs.org/colors/-/colors-0.5.1.tgz
error: npm ERR! error rolling back Error: EEXIST, rmdir '/opt/haibu/apps/tleite/LaunchTicker/package/node_modules/mongoose'
error: npm ERR! error rolling back mongoose@2.4.8 { [Error: EEXIST, rmdir '/opt/haibu/apps/tleite/LaunchTicker/package/node_modules/mongoose']
error: npm ERR! error rolling back errno: 47,
error: npm ERR! error rolling back code: 'EEXIST',
error: npm ERR! error rolling back path: '/opt/haibu/apps/tleite/LaunchTicker/package/node_modules/mongoose' }
error: npm ERR! notsup Unsupported
error: npm ERR! notsup Not compatible with your operating system or architecture: mongodb@0.9.7-2-5
error: npm ERR! notsup Valid OS: linux,darwin,freebsd
error: npm ERR! notsup Valid Arch: any
error: npm ERR! notsup Actual OS: sunos
error: npm ERR! notsup Actual Arch: x64
error:
error: npm ERR! System SunOS 5.11
error: npm ERR! command "node" "/opt/haibu/node-versions/0.6.19/bin/npm" "--cache" "/opt/haibu/apps/tleite/LaunchTicker/.npm" "--userconfig" "/opt/haibu/apps/tleite/LaunchTicker/.userconfig" "--globalconfig" "/opt/haibu/apps/tleite/LaunchTicker/.globalconfig" "install"
error: npm ERR! cwd /opt/haibu/apps/tleite/LaunchTicker/package
error: npm ERR! node -v v0.6.19
error: npm ERR! npm -v 1.1.43
error: npm ERR! code EBADPLATFORM
error: npm ERR! stack Error: Unsupported
error: npm ERR! stack at checkPlatform (/opt/haibu/node-versions/0.6.19/lib/node_modules/npm/lib/install.js:747:14)
error: npm ERR! stack at Array.1 (/opt/haibu/node-versions/0.6.19/lib/node_modules/npm/node_modules/slide/lib/bind-actor.js:15:8)
error: npm ERR! stack at LOOP (/opt/haibu/node-versions/0.6.19/lib/node_modules/npm/node_modules/slide/lib/chain.js:15:13)
error: npm ERR! stack at /opt/haibu/node-versions/0.6.19/lib/node_modules/npm/node_modules/slide/lib/chain.js:18:7
error: npm ERR! stack at checkEngine (/opt/haibu/node-versions/0.6.19/lib/node_modules/npm/lib/install.js:726:10)
error: npm ERR! stack at Array.0 (/opt/haibu/node-versions/0.6.19/lib/node_modules/npm/node_modules/slide/lib/bind-actor.js:15:8)
error: npm ERR! stack at LOOP (/opt/haibu/node-versions/0.6.19/lib/node_modules/npm/node_modules/slide/lib/chain.js:15:13)
error: npm ERR! stack at chain (/opt/haibu/node-versions/0.6.19/lib/node_modules/npm/node_modules/slide/lib/chain.js:20:4)
error: npm ERR! stack at installOne_ (/opt/haibu/node-versions/0.6.19/lib/node_modules/npm/lib/install.js:692:3)
error: npm ERR! stack at installOne (/opt/haibu/node-versions/0.6.19/lib/node_modules/npm/lib/install.js:615:3)
error: npm http GET https://registry.npmjs.org/uglify-js/1.0.6
error: npm http GET https://registry.npmjs.org/websocket-client/1.0.0
error: npm http GET https://registry.npmjs.org/xmlhttprequest/1.2.2
error: npm http 200 https://registry.npmjs.org/uglify-js/1.0.6
error: npm http GET https://registry.npmjs.org/uglify-js/-/uglify-js-1.0.6.tgz
error: npm http 200 https://registry.npmjs.org/websocket-client/1.0.0
error: npm http GET https://registry.npmjs.org/websocket-client/-/websocket-client-1.0.0.tgz
error: npm http 200 https://registry.npmjs.org/xmlhttprequest/1.2.2
error: npm http GET https://registry.npmjs.org/xmlhttprequest/-/xmlhttprequest-1.2.2.tgz
error: npm http 200 https://registry.npmjs.org/websocket-client/-/websocket-client-1.0.0.tgz
error: npm http 200 https://registry.npmjs.org/uglify-js/-/uglify-js-1.0.6.tgz
error: npm http 200 https://registry.npmjs.org/xmlhttprequest/-/xmlhttprequest-1.2.2.tgz
error: npm ERR!
error: npm ERR! Additional logging details can be found in:
error: npm ERR! /opt/haibu/apps/tleite/LaunchTicker/package/npm-debug.log
error: npm ERR! not ok code undefined
error: npm ERR! not ok code 1
error:
info: Nodejitsu not ok
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.