Skip to content

Instantly share code, notes, and snippets.

@todb-r7
Last active Oct 12, 2015
Embed
What would you like to do?
Installing Metasploit Framework manually.

Installing Metasploit on OSX

Almost certainly requires XCode and probably requires a functioanal Homebrew? This needs tons more testing.

For RVM on OSX, see: https://rvm.io/rvm/install/

\curl -L https://get.rvm.io | bash -s stable --ruby
rvm ruby --version # Returns 1.9.3-p286
git clone git://github.com/rapid7/metasploit-framework # Even better, fork and clone.
cd metasploit-framework
bundle install # Needed for rspec and some activerecord stuff, mainly.

Todo: PostgreSQL step-by-step

Start here: http://www.enterprisedb.com/products-services-training/pgdownload#osx Note that this will often will need a reboot after changing shared memory prefs.

@drew-kun

This comment has been minimized.

Copy link

@drew-kun drew-kun commented Jul 24, 2015

It's an old one… now msf works with ruby 2.1.6

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment