Skip to content
Create a gist now

Instantly share code, notes, and snippets.

Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
libmagickwand-dev : Depends: libmagickcore4-extra (= 8: but it is not going to be installed
Depends: libmagickcore-dev (= 8: but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Hi, I'm having the same problem on a brand new Ubuntu 12.04 system. Were you able to fix it?


@khelal: Solution appears to be to install libmagickcore-dev before libmagickwand-dev

sudo apt-get install imagemagick libmagickcore-dev libmagickwand-dev
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.