Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
How to fix: Nokogiri Incompatible library version: nokogiri.bundle requires version 11.0.0 or later, but libxml2.2.dylib provides version 10.0.0. dlopen bundle.open. Using homebrew on lion to install nokogiri and lixml
FIXME:
WARNING: Nokogiri was built against LibXML version 2.7.3, but has dynamically loaded 2.7.8
or
ERROR -: Incompatible library version: nokogiri.bundle requires version 11.0.0 or later, but libxml2.2.dylib provides version 10.0.0
gem uninstall nokogiri libxml-ruby
brew update
brew uninstall libxml2
brew install libxml2 --with-xml2-config
brew link --force libxml2
brew install libxslt
brew link --force libxslt
bundle config build.nokogiri -- --with-xml2-dir=/usr --with-xslt-dir=/opt/local --with-iconv-dir=/opt/local
bundle install
@m5rk

This comment has been minimized.

Copy link

commented Nov 3, 2013

Thank you, this was a very helpful recipe.

@marcboeker

This comment has been minimized.

Copy link

commented Nov 5, 2013

Awesome, thanks for this hint!

@seanmcmills

This comment has been minimized.

Copy link

commented Nov 17, 2013

Thank you! Fixed my issue perfectly.

@kennyledet

This comment has been minimized.

Copy link

commented Dec 20, 2013

Thanks, this worked for me.

@vdaubry

This comment has been minimized.

Copy link

commented Dec 23, 2013

thanks worked for me too.

@morenoh149

This comment has been minimized.

Copy link

commented Jan 6, 2014

worked for me too

@hellobelda

This comment has been minimized.

Copy link

commented Jan 12, 2014

Thank you!

@MrEmelianenko

This comment has been minimized.

Copy link

commented Jan 19, 2014

Nice! It's worked for me!

@KeithWolf

This comment has been minimized.

Copy link

commented Jan 20, 2014

Actually worked. Thank you very much!

@maykaidee

This comment has been minimized.

Copy link

commented Jan 24, 2014

This worked for us also. Thank you.

Though we had to make slight adjustments. The gem uninstall had to be run: sudo gem uninstall nokogiri libxml-ruby. There were multiple gem versions installed so all had to be uninstalled. Then bundle install threw an error: Make sure that gem install nokogiri -v '1.6.1' succeeds before bundling. Simply running: sudo gem install nokogiri -v '1.6.1' fixed the issue and then bundle install then ran fine.

@kennethjohnbalgos

This comment has been minimized.

Copy link

commented Mar 28, 2014

This works perfectly. Thank you!

@sarah

This comment has been minimized.

Copy link

commented Apr 28, 2014

Yes. Thank you. I'm on Mavericks and still thank you.

@AHaymond

This comment has been minimized.

Copy link

commented Apr 28, 2014

THANK YOU! 2 hours wasted and this fixed the issue finally!

@deekoder

This comment has been minimized.

Copy link

commented May 22, 2014

Oh thank god you posted this. I wasted like 10 hours on this.

@axrami

This comment has been minimized.

Copy link

commented Aug 12, 2014

Saved so much time, Thanks!!

@icegulch

This comment has been minimized.

Copy link

commented Oct 25, 2014

Saved my bacon too! Thank you.

@dsjoerg

This comment has been minimized.

Copy link

commented Nov 22, 2014

OMG <3 <3 <3 you can do evil deeds for the rest of your life but this good deed outweighs it.

@adriand

This comment has been minimized.

Copy link

commented Dec 17, 2014

Worked for me too, thank you!!!

@githubber

This comment has been minimized.

Copy link

commented Jan 8, 2015

This also worked for me. Thanks for the instructions!

@miyamotodev123

This comment has been minimized.

Copy link

commented Jan 10, 2015

Thank you! So happy this worked!

@Joseworks

This comment has been minimized.

Copy link

commented Jan 28, 2015

Thank you :)! It worked very well!

@neosergio

This comment has been minimized.

Copy link

commented Jan 4, 2016

Thank you. It worked very well with OS X 10.11.2

@HunterMeyer

This comment has been minimized.

Copy link

commented Jun 11, 2016

This is awesome! Thank you!

@clara101

This comment has been minimized.

Copy link

commented Jun 15, 2016

Worked like a gem!!!! Thanks so much!

@ppaulojr

This comment has been minimized.

Copy link

commented Jun 24, 2016

It worked!! Almost 3 years later!!

@airevin14

This comment has been minimized.

Copy link

commented Aug 17, 2016

Still working :)

@gastongouron

This comment has been minimized.

Copy link

commented Aug 25, 2016

Still working, nice fix!

@rabnawazPikesSoft

This comment has been minimized.

Copy link

commented Oct 27, 2016

this would work for me on ruby 2.0.0p648

ai also follow thse steps but still stuck on the same error
Reason: Incompatible library version: nokogiri.bundle requires version 11.0.0 or later, but libxml2.2.dylib provides version 10.0.0 - /Users/rabnawazjansher/.rvm/gems/ruby-2.0.0-p648/gems/nokogiri-1.6.1/lib/nokogiri/nokogiri.bundle

@samkay123

This comment has been minimized.

Copy link

commented Nov 23, 2016

Magic IT works ...

@jhmarina

This comment has been minimized.

Copy link

commented Feb 20, 2017

Thanks! it saved my day

@jnewman12

This comment has been minimized.

Copy link

commented May 8, 2017

saved my day! thanks a bunch

@Mdhvince

This comment has been minimized.

Copy link

commented Nov 14, 2017

Thanks you !! Very helpful

@alec11

This comment has been minimized.

Copy link

commented Jan 13, 2018

after all this time ... this still works in January 2018 ......

thank you so much!!!!!!!!!!

@rebeccaryang

This comment has been minimized.

Copy link

commented Feb 22, 2018

Woot! This worked for me.

@jjnevis

This comment has been minimized.

Copy link

commented Mar 13, 2018

Thanks, this is still solving issues after all this time!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.