Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Local snowplow-mini with Vagrant attempt
~/repos/snowplow-mini  master
$ git clone https://github.com/snowplow/snowplow-mini.git
~/repos/snowplow-mini  master
cd snowplow-mini
~/repos/snowplow-mini  master
$ vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Importing base box 'ubuntu/trusty64'...
==> default: Matching MAC address for NAT networking...
==> default: Checking if box 'ubuntu/trusty64' is up to date...
==> default: Setting the name of the VM: snowplow-mini-1560219549
==> default: Clearing any previously set forwarded ports...
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
default: Adapter 1: nat
default: Adapter 2: hostonly
==> default: Forwarding ports...
default: 80 (guest) => 2000 (host) (adapter 1)
default: 3000 (guest) => 3000 (host) (adapter 1)
default: 4171 (guest) => 4171 (host) (adapter 1)
default: 8080 (guest) => 8080 (host) (adapter 1)
default: 9200 (guest) => 9200 (host) (adapter 1)
default: 5601 (guest) => 5601 (host) (adapter 1)
default: 8081 (guest) => 8081 (host) (adapter 1)
default: 10000 (guest) => 10000 (host) (adapter 1)
default: 22 (guest) => 2222 (host) (adapter 1)
==> default: Running 'pre-boot' VM customizations...
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
default: SSH address: 127.0.0.1:2222
default: SSH username: vagrant
default: SSH auth method: private key
default:
default: Vagrant insecure key detected. Vagrant will automatically replace
default: this with a newly generated keypair for better security.
default:
default: Inserting generated public key within guest...
default: Removing insecure key from the guest if it's present...
default: Key inserted! Disconnecting and reconnecting using new SSH key...
==> default: Machine booted and ready!
==> default: Checking for guest additions in VM...
default: The guest additions on this VM do not match the installed version of
default: VirtualBox! In most cases this is fine, but in rare cases it can
default: prevent things such as shared folders from working properly. If you see
default: shared folder errors, please make sure the guest additions within the
default: virtual machine match the version of VirtualBox you have installed on
default: your host and reload your VM.
default:
default: Guest Additions Version: 4.3.40
default: VirtualBox Version: 5.2
==> default: Setting hostname...
==> default: Configuring and enabling network interfaces...
==> default: Exporting NFS shared folders...
==> default: Preparing to edit /etc/exports. Administrator privileges will be required...
tee: /etc/exports: Operation not permitted
tee: /etc/exports: Operation not permitted
tee: /etc/exports: Operation not permitted
The nfsd service does not appear to be running.
Starting the nfsd service
==> default: Mounting NFS shared folders...
The following SSH command responded with a non-zero exit status.
Vagrant assumes that this means the command failed!
mount -o vers=3,udp 192.168.50.1:/Users/wjensen/repos/snowplow-mini /vagrant
Stdout from the command:
Stderr from the command:
mount.nfs: mount to NFS server '192.168.50.1:/Users/wjensen/repos/snowplow-mini' failed: RPC Error: Unable to receive
✘ ~/repos/snowplow-mini  master
$ vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Checking if box 'ubuntu/trusty64' is up to date...
==> default: Running provisioner: shell...
default: Running: /var/folders/vs/l8s5nlyn4qj4xn3b4_zxs7pc0000gn/T/vagrant-shell20190611-38220-jc10ot.bash
default: Get:1 http://security.ubuntu.com trusty-security InRelease [65.9 kB]
default: Ign http://archive.ubuntu.com trusty InRelease
default: Get:2 http://archive.ubuntu.com trusty-updates InRelease [65.9 kB]
default: Get:3 http://security.ubuntu.com trusty-security/main Sources [172 kB]
default: Hit http://archive.ubuntu.com trusty-backports InRelease
default: Get:4 http://security.ubuntu.com trusty-security/universe Sources [102 kB]
default: Hit http://archive.ubuntu.com trusty Release.gpg
default: Get:5 http://archive.ubuntu.com trusty-updates/main Sources [431 kB]
default: Get:6 http://security.ubuntu.com trusty-security/main amd64 Packages [836 kB]
default: Get:7 http://security.ubuntu.com trusty-security/universe amd64 Packages [294 kB]
default: Get:8 http://archive.ubuntu.com trusty-updates/restricted Sources [6,313 B]
default: Get:9 http://archive.ubuntu.com trusty-updates/universe Sources [231 kB]
default: Get:10 http://security.ubuntu.com trusty-security/main Translation-en [448 kB]
default: Get:11 http://archive.ubuntu.com trusty-updates/multiverse Sources [7,535 B]
default: Get:12 http://security.ubuntu.com trusty-security/universe Translation-en [162 kB]
default: Get:13 http://archive.ubuntu.com trusty-updates/main amd64 Packages [1,177 kB]
default: Get:14 http://archive.ubuntu.com trusty-updates/restricted amd64 Packages [17.2 kB]
default: Get:15 http://archive.ubuntu.com trusty-updates/universe amd64 Packages [526 kB]
default: Get:16 http://archive.ubuntu.com trusty-updates/multiverse amd64 Packages [14.6 kB]
default: Get:17 http://archive.ubuntu.com trusty-updates/main Translation-en [582 kB]
default: Get:18 http://archive.ubuntu.com trusty-updates/multiverse Translation-en [7,616 B]
default: Get:19 http://archive.ubuntu.com trusty-updates/restricted Translation-en [4,028 B]
default: Get:20 http://archive.ubuntu.com trusty-updates/universe Translation-en [281 kB]
default: Get:21 http://archive.ubuntu.com trusty-backports/main Sources [9,709 B]
default: Get:22 http://archive.ubuntu.com trusty-backports/restricted Sources [28 B]
default: Get:23 http://archive.ubuntu.com trusty-backports/universe Sources [35.4 kB]
default: Get:24 http://archive.ubuntu.com trusty-backports/multiverse Sources [1,896 B]
default: Hit http://archive.ubuntu.com trusty-backports/main amd64 Packages
default: Hit http://archive.ubuntu.com trusty-backports/restricted amd64 Packages
default: Hit http://archive.ubuntu.com trusty-backports/universe amd64 Packages
default: Hit http://archive.ubuntu.com trusty-backports/multiverse amd64 Packages
default: Hit http://archive.ubuntu.com trusty-backports/main Translation-en
default: Hit http://archive.ubuntu.com trusty-backports/multiverse Translation-en
default: Hit http://archive.ubuntu.com trusty-backports/restricted Translation-en
default: Hit http://archive.ubuntu.com trusty-backports/universe Translation-en
default: Hit http://archive.ubuntu.com trusty Release
default: Get:25 http://archive.ubuntu.com trusty/main Sources [1,064 kB]
default: Get:26 http://archive.ubuntu.com trusty/restricted Sources [5,433 B]
default: Get:27 http://archive.ubuntu.com trusty/universe Sources [6,399 kB]
default: Get:28 http://archive.ubuntu.com trusty/multiverse Sources [174 kB]
default: Hit http://archive.ubuntu.com trusty/main amd64 Packages
default: Hit http://archive.ubuntu.com trusty/restricted amd64 Packages
default: Hit http://archive.ubuntu.com trusty/universe amd64 Packages
default: Hit http://archive.ubuntu.com trusty/multiverse amd64 Packages
default: Hit http://archive.ubuntu.com trusty/main Translation-en
default: Hit http://archive.ubuntu.com trusty/multiverse Translation-en
default: Hit http://archive.ubuntu.com trusty/restricted Translation-en
default: Hit http://archive.ubuntu.com trusty/universe Translation-en
default: Ign http://archive.ubuntu.com trusty/main Translation-en_US
default: Ign http://archive.ubuntu.com trusty/multiverse Translation-en_US
default: Ign http://archive.ubuntu.com trusty/restricted Translation-en_US
default: Ign http://archive.ubuntu.com trusty/universe Translation-en_US
default: Fetched 13.1 MB in 34s (378 kB/s)
default: Reading package lists...
default: Reading package lists...
default: Building dependency tree...
default: Reading state information...
default: The following extra packages will be installed:
default: build-essential dpkg-dev g++ g++-4.8 language-pack-en-base
default: libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl
default: libdpkg-perl libexpat1-dev libfile-fcntllock-perl libpython-dev
default: libpython2.7-dev libssl-doc libstdc++-4.8-dev python-chardet-whl
default: python-colorama python-colorama-whl python-distlib python-distlib-whl
default: python-html5lib python-html5lib-whl python-pip-whl python-requests-whl
default: python-setuptools python-setuptools-whl python-six-whl python-urllib3-whl
default: python-wheel python2.7-dev python3-pkg-resources zlib1g-dev
default: Suggested packages:
default: debian-keyring g++-multilib g++-4.8-multilib gcc-4.8-doc libstdc++6-4.8-dbg
default: libstdc++-4.8-doc python-genshi python-lxml python3-setuptools
default: Recommended packages:
default: python-dev-all
default: The following NEW packages will be installed:
default: build-essential dpkg-dev g++ g++-4.8 language-pack-en language-pack-en-base
default: libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl
default: libdpkg-perl libexpat1-dev libffi-dev libfile-fcntllock-perl libpython-dev
default: libpython2.7-dev libssl-dev libssl-doc libstdc++-4.8-dev python-chardet-whl
default: python-colorama python-colorama-whl python-dev python-distlib
default: python-distlib-whl python-html5lib python-html5lib-whl python-paramiko
default: python-pip python-pip-whl python-requests-whl python-setuptools
default: python-setuptools-whl python-six-whl python-urllib3-whl python-wheel
default: python2.7-dev python3-pkg-resources zlib1g-dev
default: 0 upgraded, 38 newly installed, 0 to remove and 0 not upgraded.
default: Need to get 47.1 MB of archives.
default: After this operation, 96.9 MB of additional disk space will be used.
default: Get:1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main language-pack-en-base all 1:14.04+20160720 [484 kB]
default: Get:2 http://archive.ubuntu.com/ubuntu/ trusty-updates/main language-pack-en all 1:14.04+20160720 [1,820 B]
default: Get:3 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libexpat1-dev amd64 2.1.0-4ubuntu1.4 [115 kB]
default: Get:4 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libpython2.7-dev amd64 2.7.6-8ubuntu0.5 [22.0 MB]
default: Get:5 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libstdc++-4.8-dev amd64 4.8.4-2ubuntu1~14.04.4 [1,051 kB]
default: Get:6 http://archive.ubuntu.com/ubuntu/ trusty-updates/main g++-4.8 amd64 4.8.4-2ubuntu1~14.04.4 [18.0 MB]
default: Get:7 http://archive.ubuntu.com/ubuntu/ trusty/main g++ amd64 4:4.8.2-1ubuntu6 [1,490 B]
default: Get:8 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libdpkg-perl all 1.17.5ubuntu5.8 [179 kB]
default: Get:9 http://archive.ubuntu.com/ubuntu/ trusty-updates/main dpkg-dev all 1.17.5ubuntu5.8 [726 kB]
default: Get:10 http://archive.ubuntu.com/ubuntu/ trusty/main build-essential amd64 11.6ubuntu6 [4,838 B]
default: Get:11 http://archive.ubuntu.com/ubuntu/ trusty/main libalgorithm-diff-perl all 1.19.02-3 [50.0 kB]
default: Get:12 http://archive.ubuntu.com/ubuntu/ trusty/main libalgorithm-diff-xs-perl amd64 0.04-2build4 [12.6 kB]
default: Get:13 http://archive.ubuntu.com/ubuntu/ trusty/main libalgorithm-merge-perl all 0.08-2 [12.7 kB]
default: Get:14 http://archive.ubuntu.com/ubuntu/ trusty/main libfile-fcntllock-perl amd64 0.14-2build1 [15.9 kB]
default: Get:15 http://archive.ubuntu.com/ubuntu/ trusty/main libpython-dev amd64 2.7.5-5ubuntu3 [7,078 B]
default: Get:16 http://archive.ubuntu.com/ubuntu/ trusty-updates/main zlib1g-dev amd64 1:1.2.8.dfsg-1ubuntu1.1 [166 kB]
default: Get:17 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libssl-dev amd64 1.0.1f-1ubuntu2.27 [1,076 kB]
default: Get:18 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libssl-doc all 1.0.1f-1ubuntu2.27 [972 kB]
default: Get:19 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python3-pkg-resources all 3.3-1ubuntu2 [31.7 kB]
default: Get:20 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe python-chardet-whl all 2.2.1-2~ubuntu1 [170 kB]
default: Get:21 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe python-colorama all 0.2.5-0.1ubuntu2 [18.4 kB]
default: Get:22 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe python-colorama-whl all 0.2.5-0.1ubuntu2 [18.2 kB]
default: Get:23 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python2.7-dev amd64 2.7.6-8ubuntu0.5 [269 kB]
default: Get:24 http://archive.ubuntu.com/ubuntu/ trusty/main python-dev amd64 2.7.5-5ubuntu3 [1,166 B]
default: Get:25 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe python-distlib all 0.1.8-1ubuntu1 [113 kB]
default: Get:26 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe python-distlib-whl all 0.1.8-1ubuntu1 [140 kB]
default: Get:27 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python-html5lib all 0.999-3~ubuntu1 [83.5 kB]
default: Get:28 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python-html5lib-whl all 0.999-3~ubuntu1 [109 kB]
default: Get:29 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python-paramiko all 1.10.1-1git1ubuntu0.2 [107 kB]
default: Get:30 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python-six-whl all 1.5.2-1ubuntu1.1 [10.6 kB]
default: Get:31 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python-urllib3-whl all 1.7.1-1ubuntu4.1 [63.9 kB]
default: Get:32 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python-requests-whl all 2.2.1-1ubuntu0.4 [228 kB]
default: Get:33 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python-setuptools-whl all 3.3-1ubuntu2 [244 kB]
default: Get:34 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe python-pip-whl all 1.5.4-1ubuntu4 [111 kB]
default: Get:35 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python-setuptools all 3.3-1ubuntu2 [230 kB]
default: Get:36 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe python-pip all 1.5.4-1ubuntu4 [97.3 kB]
default: Get:37 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python-wheel all 0.24.0-1~ubuntu1.1 [44.7 kB]
default: Get:38 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libffi-dev amd64 3.1~rc1+r3.0.13-12ubuntu0.2 [100 kB]
default: dpkg-preconfigure: unable to re-open stdin: No such file or directory
default: Fetched 47.1 MB in 1min 16s (619 kB/s)
default: Selecting previously unselected package language-pack-en-base.
default: (Reading database ... 63174 files and directories currently installed.)
default: Preparing to unpack .../language-pack-en-base_1%3a14.04+20160720_all.deb ...
default: Unpacking language-pack-en-base (1:14.04+20160720) ...
default: Selecting previously unselected package language-pack-en.
default: Preparing to unpack .../language-pack-en_1%3a14.04+20160720_all.deb ...
default: Unpacking language-pack-en (1:14.04+20160720) ...
default: Selecting previously unselected package libexpat1-dev:amd64.
default: Preparing to unpack .../libexpat1-dev_2.1.0-4ubuntu1.4_amd64.deb ...
default: Unpacking libexpat1-dev:amd64 (2.1.0-4ubuntu1.4) ...
default: Selecting previously unselected package libpython2.7-dev:amd64.
default: Preparing to unpack .../libpython2.7-dev_2.7.6-8ubuntu0.5_amd64.deb ...
default: Unpacking libpython2.7-dev:amd64 (2.7.6-8ubuntu0.5) ...
default: Selecting previously unselected package libstdc++-4.8-dev:amd64.
default: Preparing to unpack .../libstdc++-4.8-dev_4.8.4-2ubuntu1~14.04.4_amd64.deb ...
default: Unpacking libstdc++-4.8-dev:amd64 (4.8.4-2ubuntu1~14.04.4) ...
default: Selecting previously unselected package g++-4.8.
default: Preparing to unpack .../g++-4.8_4.8.4-2ubuntu1~14.04.4_amd64.deb ...
default: Unpacking g++-4.8 (4.8.4-2ubuntu1~14.04.4) ...
default: Selecting previously unselected package g++.
default: Preparing to unpack .../g++_4%3a4.8.2-1ubuntu6_amd64.deb ...
default: Unpacking g++ (4:4.8.2-1ubuntu6) ...
default: Selecting previously unselected package libdpkg-perl.
default: Preparing to unpack .../libdpkg-perl_1.17.5ubuntu5.8_all.deb ...
default: Unpacking libdpkg-perl (1.17.5ubuntu5.8) ...
default: Selecting previously unselected package dpkg-dev.
default: Preparing to unpack .../dpkg-dev_1.17.5ubuntu5.8_all.deb ...
default: Unpacking dpkg-dev (1.17.5ubuntu5.8) ...
default: Selecting previously unselected package build-essential.
default: Preparing to unpack .../build-essential_11.6ubuntu6_amd64.deb ...
default: Unpacking build-essential (11.6ubuntu6) ...
default: Selecting previously unselected package libalgorithm-diff-perl.
default: Preparing to unpack .../libalgorithm-diff-perl_1.19.02-3_all.deb ...
default: Unpacking libalgorithm-diff-perl (1.19.02-3) ...
default: Selecting previously unselected package libalgorithm-diff-xs-perl.
default: Preparing to unpack .../libalgorithm-diff-xs-perl_0.04-2build4_amd64.deb ...
default: Unpacking libalgorithm-diff-xs-perl (0.04-2build4) ...
default: Selecting previously unselected package libalgorithm-merge-perl.
default: Preparing to unpack .../libalgorithm-merge-perl_0.08-2_all.deb ...
default: Unpacking libalgorithm-merge-perl (0.08-2) ...
default: Selecting previously unselected package libfile-fcntllock-perl.
default: Preparing to unpack .../libfile-fcntllock-perl_0.14-2build1_amd64.deb ...
default: Unpacking libfile-fcntllock-perl (0.14-2build1) ...
default: Selecting previously unselected package libpython-dev:amd64.
default: Preparing to unpack .../libpython-dev_2.7.5-5ubuntu3_amd64.deb ...
default: Unpacking libpython-dev:amd64 (2.7.5-5ubuntu3) ...
default: Selecting previously unselected package zlib1g-dev:amd64.
default: Preparing to unpack .../zlib1g-dev_1%3a1.2.8.dfsg-1ubuntu1.1_amd64.deb ...
default: Unpacking zlib1g-dev:amd64 (1:1.2.8.dfsg-1ubuntu1.1) ...
default: Selecting previously unselected package libssl-dev:amd64.
default: Preparing to unpack .../libssl-dev_1.0.1f-1ubuntu2.27_amd64.deb ...
default: Unpacking libssl-dev:amd64 (1.0.1f-1ubuntu2.27) ...
default: Selecting previously unselected package libssl-doc.
default: Preparing to unpack .../libssl-doc_1.0.1f-1ubuntu2.27_all.deb ...
default: Unpacking libssl-doc (1.0.1f-1ubuntu2.27) ...
default: Selecting previously unselected package python3-pkg-resources.
default: Preparing to unpack .../python3-pkg-resources_3.3-1ubuntu2_all.deb ...
default: Unpacking python3-pkg-resources (3.3-1ubuntu2) ...
default: Selecting previously unselected package python-chardet-whl.
default: Preparing to unpack .../python-chardet-whl_2.2.1-2~ubuntu1_all.deb ...
default: Unpacking python-chardet-whl (2.2.1-2~ubuntu1) ...
default: Selecting previously unselected package python-colorama.
default: Preparing to unpack .../python-colorama_0.2.5-0.1ubuntu2_all.deb ...
default: Unpacking python-colorama (0.2.5-0.1ubuntu2) ...
default: Selecting previously unselected package python-colorama-whl.
default: Preparing to unpack .../python-colorama-whl_0.2.5-0.1ubuntu2_all.deb ...
default: Unpacking python-colorama-whl (0.2.5-0.1ubuntu2) ...
default: Selecting previously unselected package python2.7-dev.
default: Preparing to unpack .../python2.7-dev_2.7.6-8ubuntu0.5_amd64.deb ...
default: Unpacking python2.7-dev (2.7.6-8ubuntu0.5) ...
default: Selecting previously unselected package python-dev.
default: Preparing to unpack .../python-dev_2.7.5-5ubuntu3_amd64.deb ...
default: Unpacking python-dev (2.7.5-5ubuntu3) ...
default: Selecting previously unselected package python-distlib.
default: Preparing to unpack .../python-distlib_0.1.8-1ubuntu1_all.deb ...
default: Unpacking python-distlib (0.1.8-1ubuntu1) ...
default: Selecting previously unselected package python-distlib-whl.
default: Preparing to unpack .../python-distlib-whl_0.1.8-1ubuntu1_all.deb ...
default: Unpacking python-distlib-whl (0.1.8-1ubuntu1) ...
default: Selecting previously unselected package python-html5lib.
default: Preparing to unpack .../python-html5lib_0.999-3~ubuntu1_all.deb ...
default: Unpacking python-html5lib (0.999-3~ubuntu1) ...
default: Selecting previously unselected package python-html5lib-whl.
default: Preparing to unpack .../python-html5lib-whl_0.999-3~ubuntu1_all.deb ...
default: Unpacking python-html5lib-whl (0.999-3~ubuntu1) ...
default: Selecting previously unselected package python-paramiko.
default: Preparing to unpack .../python-paramiko_1.10.1-1git1ubuntu0.2_all.deb ...
default: Unpacking python-paramiko (1.10.1-1git1ubuntu0.2) ...
default: Selecting previously unselected package python-six-whl.
default: Preparing to unpack .../python-six-whl_1.5.2-1ubuntu1.1_all.deb ...
default: Unpacking python-six-whl (1.5.2-1ubuntu1.1) ...
default: Selecting previously unselected package python-urllib3-whl.
default: Preparing to unpack .../python-urllib3-whl_1.7.1-1ubuntu4.1_all.deb ...
default: Unpacking python-urllib3-whl (1.7.1-1ubuntu4.1) ...
default: Selecting previously unselected package python-requests-whl.
default: Preparing to unpack .../python-requests-whl_2.2.1-1ubuntu0.4_all.deb ...
default: Unpacking python-requests-whl (2.2.1-1ubuntu0.4) ...
default: Selecting previously unselected package python-setuptools-whl.
default: Preparing to unpack .../python-setuptools-whl_3.3-1ubuntu2_all.deb ...
default: Unpacking python-setuptools-whl (3.3-1ubuntu2) ...
default: Selecting previously unselected package python-pip-whl.
default: Preparing to unpack .../python-pip-whl_1.5.4-1ubuntu4_all.deb ...
default: Unpacking python-pip-whl (1.5.4-1ubuntu4) ...
default: Selecting previously unselected package python-setuptools.
default: Preparing to unpack .../python-setuptools_3.3-1ubuntu2_all.deb ...
default: Unpacking python-setuptools (3.3-1ubuntu2) ...
default: Selecting previously unselected package python-pip.
default: Preparing to unpack .../python-pip_1.5.4-1ubuntu4_all.deb ...
default: Unpacking python-pip (1.5.4-1ubuntu4) ...
default: Selecting previously unselected package python-wheel.
default: Preparing to unpack .../python-wheel_0.24.0-1~ubuntu1.1_all.deb ...
default: Unpacking python-wheel (0.24.0-1~ubuntu1.1) ...
default: Selecting previously unselected package libffi-dev:amd64.
default: Preparing to unpack .../libffi-dev_3.1~rc1+r3.0.13-12ubuntu0.2_amd64.deb ...
default: Unpacking libffi-dev:amd64 (3.1~rc1+r3.0.13-12ubuntu0.2) ...
default: Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
default: Processing triggers for install-info (5.2.0.dfsg.1-2) ...
default: Setting up libexpat1-dev:amd64 (2.1.0-4ubuntu1.4) ...
default: Setting up libpython2.7-dev:amd64 (2.7.6-8ubuntu0.5) ...
default: Setting up libstdc++-4.8-dev:amd64 (4.8.4-2ubuntu1~14.04.4) ...
default: Setting up g++-4.8 (4.8.4-2ubuntu1~14.04.4) ...
default: Setting up g++ (4:4.8.2-1ubuntu6) ...
default: update-alternatives:
default: using /usr/bin/g++ to provide /usr/bin/c++ (c++) in auto mode
default: Setting up libdpkg-perl (1.17.5ubuntu5.8) ...
default: Setting up dpkg-dev (1.17.5ubuntu5.8) ...
default: Setting up build-essential (11.6ubuntu6) ...
default: Setting up libalgorithm-diff-perl (1.19.02-3) ...
default: Setting up libalgorithm-diff-xs-perl (0.04-2build4) ...
default: Setting up libalgorithm-merge-perl (0.08-2) ...
default: Setting up libfile-fcntllock-perl (0.14-2build1) ...
default: Setting up libpython-dev:amd64 (2.7.5-5ubuntu3) ...
default: Setting up zlib1g-dev:amd64 (1:1.2.8.dfsg-1ubuntu1.1) ...
default: Setting up libssl-dev:amd64 (1.0.1f-1ubuntu2.27) ...
default: Setting up libssl-doc (1.0.1f-1ubuntu2.27) ...
default: Setting up python3-pkg-resources (3.3-1ubuntu2) ...
default: Setting up python-chardet-whl (2.2.1-2~ubuntu1) ...
default: Setting up python-colorama (0.2.5-0.1ubuntu2) ...
default: Setting up python-colorama-whl (0.2.5-0.1ubuntu2) ...
default: Setting up python2.7-dev (2.7.6-8ubuntu0.5) ...
default: Setting up python-dev (2.7.5-5ubuntu3) ...
default: Setting up python-distlib (0.1.8-1ubuntu1) ...
default: Setting up python-distlib-whl (0.1.8-1ubuntu1) ...
default: Setting up python-html5lib (0.999-3~ubuntu1) ...
default: Setting up python-html5lib-whl (0.999-3~ubuntu1) ...
default: Setting up python-paramiko (1.10.1-1git1ubuntu0.2) ...
default: Setting up python-six-whl (1.5.2-1ubuntu1.1) ...
default: Setting up python-urllib3-whl (1.7.1-1ubuntu4.1) ...
default: Setting up python-requests-whl (2.2.1-1ubuntu0.4) ...
default: Setting up python-setuptools-whl (3.3-1ubuntu2) ...
default: Setting up python-pip-whl (1.5.4-1ubuntu4) ...
default: Setting up python-setuptools (3.3-1ubuntu2) ...
default: Setting up python-pip (1.5.4-1ubuntu4) ...
default: Setting up python-wheel (0.24.0-1~ubuntu1.1) ...
default: Setting up libffi-dev:amd64 (3.1~rc1+r3.0.13-12ubuntu0.2) ...
default: Setting up language-pack-en (1:14.04+20160720) ...
default: Setting up language-pack-en-base (1:14.04+20160720) ...
default: Generating locales...
default: en_AG.UTF-8...
default: done
default: en_AU.UTF-8...
default: done
default: en_BW.UTF-8...
default: done
default: en_CA.UTF-8...
default: done
default: en_DK.UTF-8...
default: done
default: en_GB.UTF-8...
default: done
default: en_HK.UTF-8...
default: done
default: en_IE.UTF-8...
default: done
default: en_IN.UTF-8...
default: done
default: en_NG.UTF-8...
default: done
default: en_NZ.UTF-8...
default: done
default: en_PH.UTF-8...
default: done
default: en_SG.UTF-8...
default: done
default: en_US.UTF-8...
default: up-to-date
default: en_ZA.UTF-8...
default: done
default: en_ZM.UTF-8...
default: done
default: en_ZW.UTF-8...
default: done
default: Generation complete.
default: Downloading/unpacking pip from https://files.pythonhosted.org/packages/5c/e0/be401c003291b56efc55aeba6a80ab790d3d4cece2778288d65323009420/pip-19.1.1-py2.py3-none-any.whl#sha256=993134f0475471b91452ca029d4390dc8f298ac63a712814f101cd1b6db46676
default: Installing collected packages: pip
default: Found existing installation: pip 1.5.4
default: Not uninstalling pip at /usr/lib/python2.7/dist-packages, owned by OS
default: Successfully installed pip
default: Cleaning up...
default: DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
default: Collecting markupsafe
default: /usr/local/lib/python2.7/dist-packages/pip/_vendor/urllib3/util/ssl_.py:354: SNIMissingWarning: An HTTPS request has been made, but the SNI (Server Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
default: SNIMissingWarning
default: /usr/local/lib/python2.7/dist-packages/pip/_vendor/urllib3/util/ssl_.py:150: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
default: InsecurePlatformWarning
default: /usr/local/lib/python2.7/dist-packages/pip/_vendor/urllib3/util/ssl_.py:150: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
default: InsecurePlatformWarning
default: Downloading https://files.pythonhosted.org/packages/fb/40/f3adb7cf24a8012813c5edb20329eb22d5d8e2a0ecf73d21d6b85865da11/MarkupSafe-1.1.1-cp27-cp27mu-manylinux1_x86_64.whl
default: Installing collected packages: markupsafe
default: Successfully installed markupsafe-1.1.1
default: /usr/local/lib/python2.7/dist-packages/pip/_vendor/urllib3/util/ssl_.py:150: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
default: InsecurePlatformWarning
default: DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
default: Requirement already satisfied: setuptools in /usr/lib/python2.7/dist-packages (3.3)
default: DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
default: Collecting ansible
default: /usr/local/lib/python2.7/dist-packages/pip/_vendor/urllib3/util/ssl_.py:354: SNIMissingWarning: An HTTPS request has been made, but the SNI (Server Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
default: SNIMissingWarning
default: /usr/local/lib/python2.7/dist-packages/pip/_vendor/urllib3/util/ssl_.py:150: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
default: InsecurePlatformWarning
default: /usr/local/lib/python2.7/dist-packages/pip/_vendor/urllib3/util/ssl_.py:150: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
default: InsecurePlatformWarning
default: Downloading https://files.pythonhosted.org/packages/fd/e2/94ecc42e0948c825d9e118cd84246ea57b850041fb9bf96ca24877062766/ansible-2.8.1.tar.gz (14.3MB)
default: Collecting jinja2 (from ansible)
default: Downloading https://files.pythonhosted.org/packages/1d/e7/fd8b501e7a6dfe492a433deb7b9d833d39ca74916fa8bc63dd1a4947a671/Jinja2-2.10.1-py2.py3-none-any.whl (124kB)
default: Requirement already satisfied: PyYAML in /usr/lib/python2.7/dist-packages (from ansible) (3.10)
default: Collecting cryptography (from ansible)
default: Downloading https://files.pythonhosted.org/packages/e6/68/50698ce24c61db7d44d93a5043c621a0ca7839d4ef9dff913e6ab465fc92/cryptography-2.7-cp27-cp27mu-manylinux1_x86_64.whl (2.3MB)
default: Requirement already satisfied: MarkupSafe>=0.23 in /usr/local/lib/python2.7/dist-packages (from jinja2->ansible) (1.1.1)
default: Collecting enum34; python_version < "3" (from cryptography->ansible)
default: Downloading https://files.pythonhosted.org/packages/c5/db/e56e6b4bbac7c4a06de1c50de6fe1ef3810018ae11732a50f15f62c7d050/enum34-1.1.6-py2-none-any.whl
default: Requirement already satisfied: six>=1.4.1 in /usr/lib/python2.7/dist-packages (from cryptography->ansible) (1.5.2)
default: Collecting cffi!=1.11.3,>=1.8 (from cryptography->ansible)
default: Downloading https://files.pythonhosted.org/packages/8d/e9/0c8afd1579e5cf7bc0f06fbcd7cdb954cbc0baadd505973949a99337da1c/cffi-1.12.3-cp27-cp27mu-manylinux1_x86_64.whl (415kB)
default: Collecting asn1crypto>=0.21.0 (from cryptography->ansible)
default: Downloading https://files.pythonhosted.org/packages/ea/cd/35485615f45f30a510576f1a56d1e0a7ad7bd8ab5ed7cdc600ef7cd06222/asn1crypto-0.24.0-py2.py3-none-any.whl (101kB)
default: Collecting ipaddress; python_version < "3" (from cryptography->ansible)
default: Downloading https://files.pythonhosted.org/packages/fc/d0/7fc3a811e011d4b388be48a0e381db8d990042df54aa4ef4599a31d39853/ipaddress-1.0.22-py2.py3-none-any.whl
default: Collecting pycparser (from cffi!=1.11.3,>=1.8->cryptography->ansible)
default: Downloading https://files.pythonhosted.org/packages/68/9e/49196946aee219aead1290e00d1e7fdeab8567783e83e1b9ab5585e6206a/pycparser-2.19.tar.gz (158kB)
default: Building wheels for collected packages: ansible, pycparser
default: Building wheel for ansible (setup.py): started
default: Building wheel for ansible (setup.py): finished with status 'done'
default: Stored in directory: /root/.cache/pip/wheels/c8/b7/a9/e89f480562bfb3326ef3d8774b8cf5880465ecd09150bad26e
default: Building wheel for pycparser (setup.py): started
default: Building wheel for pycparser (setup.py): finished with status 'done'
default: Stored in directory: /root/.cache/pip/wheels/f2/9a/90/de94f8556265ddc9d9c8b271b0f63e57b26fb1d67a45564511
default: Successfully built ansible pycparser
default: Installing collected packages: jinja2, enum34, pycparser, cffi, asn1crypto, ipaddress, cryptography, ansible
default: Successfully installed ansible-2.8.1 asn1crypto-0.24.0 cffi-1.12.3 cryptography-2.7 enum34-1.1.6 ipaddress-1.0.22 jinja2-2.10.1 pycparser-2.19
default: /tmp/vagrant-shell: line 23: cd: /vagrant/vagrant/..: No such file or directory
default: /usr/local/lib/python2.7/dist-packages/cryptography/hazmat/primitives/constant_time.py:26: CryptographyDeprecationWarning: Support for your Python version is deprecated. The next version of cryptography will remove support. Please upgrade to a release (2.7.7+) that supports hmac.compare_digest as soon as possible.
default: utils.PersistentlyDeprecated2018,
default: Usage: ansible-playbook [options] playbook.yml [playbook2 ...]
default: ansible-playbook: error: no such option: --sudo
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.
✘ ~/repos/snowplow-mini  master
$ vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Checking if box 'ubuntu/trusty64' is up to date...
==> default: Machine already provisioned. Run `vagrant provision` or use the `--provision`
==> default: flag to force provisioning. Provisioners marked to run always will still run.
~/repos/snowplow-mini  master
$ vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Checking if box 'ubuntu/trusty64' is up to date...
==> default: Machine already provisioned. Run `vagrant provision` or use the `--provision`
==> default: flag to force provisioning. Provisioners marked to run always will still run.
~/repos/snowplow-mini  master
$ vagrant port
The forwarded ports for the machine are listed below. Please note that
these values may differ from values configured in the Vagrantfile if the
provider supports automatic port collision detection and resolution.
22 (guest) => 2222 (host)
10000 (guest) => 10000 (host)
80 (guest) => 2000 (host)
3000 (guest) => 3000 (host)
4171 (guest) => 4171 (host)
5601 (guest) => 5601 (host)
8080 (guest) => 8080 (host)
8081 (guest) => 8081 (host)
9200 (guest) => 9200 (host)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.