Skip to content

Instantly share code, notes, and snippets.

@weidagang
Last active December 13, 2015 23:48
Show Gist options
  • Star 0 You must be signed in to star a gist
  • Fork 0 You must be signed in to fork a gist
  • Save weidagang/4993893 to your computer and use it in GitHub Desktop.
Save weidagang/4993893 to your computer and use it in GitHub Desktop.
Given a string of characters, print its permutations in alphbetic order. Sample input: bbjd; Sample output: bbdj, bbjd, bdbj, ..., jbdb, jdbb
/*
Given a string of characters, print its permutations in alphbetic order.
Sample input: bbjd;
Sample output: bbdj, bbjd, bdbj, ..., jbdb, jdbb
*/
#include <iostream>
#include <string>
#include <algorithm>
int main() {
std::string line;
while (std::cin >> line) {
std::sort(&line[0], &line[0] + line.length());
do {
std::cout << line << std::endl;
}
while (std::next_permutation(&line[0], &line[0] + line.length()));
}
return 0;
}
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment