Skip to content

Instantly share code, notes, and snippets.

🎯
Focusing

Georges Haddad xplodedthemes

🎯
Focusing
Block or report user

Report or block xplodedthemes

Hide content and notifications from this user.

Learn more about blocking users

Contact Support about this user’s behavior.

Learn more about reporting abuse

Report abuse
View GitHub Profile
@xplodedthemes
xplodedthemes / edd.php
Last active Jan 18, 2019
Freemius EDD Migration Helper in case EDD License keys have a custom prefix and are over 32 chars.
View edd.php
<?php
/*
....
Within plugin EDD Migration Client edd.php
*/
/**
* You should use your own unique CLASS name, and be sure to replace it
* throughout this file. For example, if your product's name is "Awesome Product"
@xplodedthemes
xplodedthemes / .env
Last active Dec 16, 2018
Ticksy External Purchase Verification Freemius Integration
View .env
FS_API_SCOPE="developer"
FS_API_DEV_ID=000
FS_API_PUBLIC_KEY=""
FS_API_SECRET_KEY=""
TICKSY_SECRET_KEY=""
@xplodedthemes
xplodedthemes / nightmare-on-amazon-linux.MD
Last active Jul 20, 2017 — forked from dimkir/nightmare-on-amazon-linux.MD
How to run nightmare on Amazon Linux
View nightmare-on-amazon-linux.MD

Running nightmare on Amazon Linux

You may have thought of running nightmare on AWS Lambda. But before we can run it on Lambda, we need first to make it run on Amazon Linux.

Provision instance which replicates Lambda environment

According to AWS Documentation on Lambda Execution Environment and available Libraries we would need this AMI image with this alias amzn-ami-hvm-2016.03.3.x86_64-gp2. Keep in mind that AMI-image-id for this instance would be different in different regions (eg):

  • In eu-west-1 - ami-f9dd458a
  • In us-east-1 - ami-6869aa05
You can’t perform that action at this time.