Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
pyenv install for CentOS 6.5 x86_64
#!/bin/zsh
# pyenv install for CentOS 6.5 x86_64
yum install -y gcc gcc-c++ make git patch openssl-devel zlib-devel readline-devel sqlite-devel bzip2-devel
git clone git://github.com/yyuu/pyenv.git ~/.pyenv
export PATH="$HOME/.pyenv/bin:$PATH"
eval "$(pyenv init -)"
cat << _PYENVCONF_ >> ~/.zshrc
export PATH="$HOME/.pyenv/bin:$PATH"
eval "$(pyenv init -)"
_PYENVCONF_
pyenv install 2.7.6
pyenv versions
pyenv shell 2.7.6
pyenv global 2.7.6
pyenv versions
pyenv rehash
@y2k-shubham

This comment has been minimized.

Copy link

@y2k-shubham y2k-shubham commented Oct 10, 2018

I had to install these additional packages using yum, as mentioned here, to be able to install python 3.7.0 using pyenv on EMR

  • sudo yum -y install zlib
  • sudo yum -y install libffi-devel
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.