Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Superpowers build error
V-97YG3QD:superpowers (master) $ sudo npm run build
> superpowers@0.19.0 build /Users/zachcarter/Projects/superpowers
> node scripts/build.js
2016-01-23T17:26:43.486Z - Build paths: /, /SupCore, /SupClient, /server, /client, /launcher, /systems/game/SupEngine, /systems/game/SupRuntime, /systems/game/plugins/common/home, /systems/game/plugins/common/settings, /systems/game/plugins/common/textEditorWidget, /systems/game/plugins/default/arcadePhysics2D, /systems/game/plugins/default/cubicModel, /systems/game/plugins/default/documentation, /systems/game/plugins/default/font, /systems/game/plugins/default/gameSettings, /systems/game/plugins/default/light, /systems/game/plugins/default/model, /systems/game/plugins/default/projectSettings, /systems/game/plugins/default/scene, /systems/game/plugins/default/shader, /systems/game/plugins/default/sound, /systems/game/plugins/default/sprite, /systems/game/plugins/default/tileMap, /systems/game/plugins/default/transformHelpers, /systems/game/plugins/default/typescript, /systems/game/plugins/extra/cannonjs, /systems/game/plugins/extra/eventEmitter, /systems/game/plugins/extra/p2js, /systems/game/plugins/extra/rngjs, /systems/game/plugins/extra/socketio, /systems/game/plugins/extra/tweenjs
2016-01-23T17:26:43.492Z - Building / (1/32)
2016-01-23T17:26:47.321Z - Building /SupCore (2/32)
/Users/zachcarter/Projects/superpowers/SupCore/gulpfile.js:14
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
2016-01-23T17:26:47.533Z - Building /SupClient (3/32)
/Users/zachcarter/Projects/superpowers/SupClient/gulpfile.js:14
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
2016-01-23T17:26:47.735Z - Building /server (4/32)
/Users/zachcarter/Projects/superpowers/server/gulpfile.js:14
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
2016-01-23T17:26:47.926Z - Building /client (5/32)
/Users/zachcarter/Projects/superpowers/client/gulpfile.js:92
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
2016-01-23T17:26:48.140Z - Building /launcher (6/32)
/Users/zachcarter/Projects/superpowers/launcher/gulpfile.js:29
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
2016-01-23T17:26:48.340Z - Building /systems/game/SupEngine (7/32)
/Users/zachcarter/Projects/superpowers/systems/game/SupEngine/gulpfile.js:11
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
2016-01-23T17:26:49.188Z - Building /systems/game/SupRuntime (8/32)
/Users/zachcarter/Projects/superpowers/systems/game/SupRuntime/gulpfile.js:19
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
2016-01-23T17:26:49.397Z - Building /systems/game/plugins/common/home (9/32)
> superpowers-common-home-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/common/home
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-common-home-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-common-home-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-common-home-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-common-home-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-common-home-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/common/home/npm-debug.log
2016-01-23T17:26:50.076Z - Building /systems/game/plugins/common/settings (10/32)
> superpowers-common-settings-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/common/settings
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-common-settings-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-common-settings-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-common-settings-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-common-settings-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-common-settings-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/common/settings/npm-debug.log
2016-01-23T17:26:50.753Z - Building /systems/game/plugins/common/textEditorWidget (11/32)
> superpowers-common-text-editor-widget-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/common/textEditorWidget
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=. && gulp --gulpfile=widgetGulpfile.js
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-common-text-editor-widget-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=. && gulp --gulpfile=widgetGulpfile.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-common-text-editor-widget-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=. && gulp --gulpfile=widgetGulpfile.js'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-common-text-editor-widget-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=. && gulp --gulpfile=widgetGulpfile.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-common-text-editor-widget-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-common-text-editor-widget-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/common/textEditorWidget/npm-debug.log
2016-01-23T17:26:52.103Z - Building /systems/game/plugins/default/arcadePhysics2D (12/32)
> superpowers-game-default-arcade-physics-2d-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/arcadePhysics2D
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-default-arcade-physics-2d-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-default-arcade-physics-2d-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-default-arcade-physics-2d-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-default-arcade-physics-2d-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-default-arcade-physics-2d-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/arcadePhysics2D/npm-debug.log
2016-01-23T17:26:52.802Z - Building /systems/game/plugins/default/cubicModel (13/32)
> superpowers-game-default-cubic-model-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/cubicModel
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-default-cubic-model-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-default-cubic-model-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-default-cubic-model-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-default-cubic-model-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-default-cubic-model-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/cubicModel/npm-debug.log
2016-01-23T17:26:53.505Z - Building /systems/game/plugins/default/documentation (14/32)
> superpowers-game-default-documentation-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/documentation
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-default-documentation-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-default-documentation-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-default-documentation-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-default-documentation-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-default-documentation-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/documentation/npm-debug.log
2016-01-23T17:26:54.831Z - Building /systems/game/plugins/default/font (15/32)
> superpowers-game-default-font-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/font
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-default-font-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-default-font-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-default-font-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-default-font-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-default-font-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/font/npm-debug.log
2016-01-23T17:26:55.507Z - Building /systems/game/plugins/default/gameSettings (16/32)
> superpowers-game-default-game-settings-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/gameSettings
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-default-game-settings-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-default-game-settings-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-default-game-settings-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-default-game-settings-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-default-game-settings-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/gameSettings/npm-debug.log
2016-01-23T17:26:56.180Z - Building /systems/game/plugins/default/light (17/32)
> superpowers-game-default-light-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/light
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-default-light-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-default-light-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-default-light-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-default-light-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-default-light-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/light/npm-debug.log
2016-01-23T17:26:56.852Z - Building /systems/game/plugins/default/model (18/32)
> superpowers-game-default-model-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/model
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-default-model-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-default-model-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-default-model-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-default-model-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-default-model-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/model/npm-debug.log
2016-01-23T17:26:57.547Z - Building /systems/game/plugins/default/projectSettings (19/32)
> superpowers-game-default-project-settings-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/projectSettings
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-default-project-settings-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-default-project-settings-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-default-project-settings-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-default-project-settings-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-default-project-settings-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/projectSettings/npm-debug.log
2016-01-23T17:26:58.243Z - Building /systems/game/plugins/default/scene (20/32)
> superpowers-game-default-scene-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/scene
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=. && gulp --gulpfile=sceneGulpfile.js
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-default-scene-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=. && gulp --gulpfile=sceneGulpfile.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-default-scene-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=. && gulp --gulpfile=sceneGulpfile.js'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-default-scene-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=. && gulp --gulpfile=sceneGulpfile.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-default-scene-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-default-scene-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/scene/npm-debug.log
2016-01-23T17:26:58.929Z - Building /systems/game/plugins/default/shader (21/32)
> superpowers-game-default-shader-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/shader
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-default-shader-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-default-shader-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-default-shader-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-default-shader-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-default-shader-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/shader/npm-debug.log
2016-01-23T17:27:00.248Z - Building /systems/game/plugins/default/sound (22/32)
> superpowers-game-default-sound-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/sound
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-default-sound-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-default-sound-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-default-sound-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-default-sound-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-default-sound-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/sound/npm-debug.log
2016-01-23T17:27:00.932Z - Building /systems/game/plugins/default/sprite (23/32)
> superpowers-game-default-sprite-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/sprite
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-default-sprite-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-default-sprite-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-default-sprite-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-default-sprite-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-default-sprite-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/sprite/npm-debug.log
2016-01-23T17:27:01.601Z - Building /systems/game/plugins/default/tileMap (24/32)
> superpowers-game-default-tile-map-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/tileMap
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-default-tile-map-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-default-tile-map-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-default-tile-map-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-default-tile-map-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-default-tile-map-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/tileMap/npm-debug.log
2016-01-23T17:27:02.307Z - Building /systems/game/plugins/default/transformHelpers (25/32)
> superpowers-game-default-transform-helpers-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/transformHelpers
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-default-transform-helpers-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-default-transform-helpers-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-default-transform-helpers-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-default-transform-helpers-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-default-transform-helpers-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/transformHelpers/npm-debug.log
2016-01-23T17:27:02.975Z - Building /systems/game/plugins/default/typescript (26/32)
> superpowers-game-default-typescript-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/typescript
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=. && gulp --gulpfile=workerGulpfile.js
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-default-typescript-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=. && gulp --gulpfile=workerGulpfile.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-default-typescript-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=. && gulp --gulpfile=workerGulpfile.js'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-default-typescript-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=. && gulp --gulpfile=workerGulpfile.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-default-typescript-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-default-typescript-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/default/typescript/npm-debug.log
2016-01-23T17:27:04.354Z - Building /systems/game/plugins/extra/cannonjs (27/32)
> superpowers-game-extra-cannonjs-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/cannonjs
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-extra-cannonjs-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-extra-cannonjs-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-extra-cannonjs-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-extra-cannonjs-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-extra-cannonjs-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/cannonjs/npm-debug.log
2016-01-23T17:27:05.691Z - Building /systems/game/plugins/extra/eventEmitter (28/32)
> superpowers-game-extra-event-emitter-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/eventEmitter
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-extra-event-emitter-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-extra-event-emitter-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-extra-event-emitter-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-extra-event-emitter-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-extra-event-emitter-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/eventEmitter/npm-debug.log
2016-01-23T17:27:06.371Z - Building /systems/game/plugins/extra/p2js (29/32)
> superpowers-game-extra-p2js-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/p2js
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-extra-p2js-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-extra-p2js-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-extra-p2js-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-extra-p2js-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-extra-p2js-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/p2js/npm-debug.log
2016-01-23T17:27:07.698Z - Building /systems/game/plugins/extra/rngjs (30/32)
> superpowers-game-extra-rngjs-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/rngjs
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-extra-rngjs-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-extra-rngjs-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-extra-rngjs-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-extra-rngjs-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-extra-rngjs-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/rngjs/npm-debug.log
2016-01-23T17:27:08.405Z - Building /systems/game/plugins/extra/socketio (31/32)
> superpowers-game-extra-socketio-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/socketio
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-extra-socketio-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-extra-socketio-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-extra-socketio-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-extra-socketio-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-extra-socketio-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/socketio/npm-debug.log
2016-01-23T17:27:09.854Z - Building /systems/game/plugins/extra/tweenjs (32/32)
> superpowers-game-extra-tweenjs-plugin@1.0.0 build /Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/tweenjs
> gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
/Users/zachcarter/Projects/superpowers/scripts/pluginGulpfile.js:50
.on("error", () => { failed = true; })
^
SyntaxError: Unexpected token )
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Liftoff.handleArguments (/Users/zachcarter/Projects/superpowers/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/Users/zachcarter/Projects/superpowers/node_modules/liftoff/index.js:192:16)
at module.exports (/Users/zachcarter/Projects/superpowers/node_modules/flagged-respawn/index.js:17:3)
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers-game-extra-tweenjs-plugin@1.0.0 build: `gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers-game-extra-tweenjs-plugin@1.0.0 build script 'gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers-game-extra-tweenjs-plugin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp --gulpfile=../../../../../scripts/pluginGulpfile.js --cwd=.
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers-game-extra-tweenjs-plugin
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers-game-extra-tweenjs-plugin
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/tweenjs/npm-debug.log
2016-01-23T17:27:11.173Z - There were errors:
[/Users/zachcarter/Projects/superpowers/SupCore] gulp exited with status code 1
[/Users/zachcarter/Projects/superpowers/SupClient] gulp exited with status code 1
[/Users/zachcarter/Projects/superpowers/server] gulp exited with status code 1
[/Users/zachcarter/Projects/superpowers/client] gulp exited with status code 1
[/Users/zachcarter/Projects/superpowers/launcher] gulp exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/SupEngine] gulp exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/SupRuntime] gulp exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/common/home] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/common/settings] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/common/textEditorWidget] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/default/arcadePhysics2D] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/default/cubicModel] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/default/documentation] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/default/font] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/default/gameSettings] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/default/light] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/default/model] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/default/projectSettings] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/default/scene] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/default/shader] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/default/sound] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/default/sprite] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/default/tileMap] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/default/transformHelpers] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/default/typescript] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/cannonjs] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/eventEmitter] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/p2js] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/rngjs] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/socketio] `npm run build` exited with status code 1
[/Users/zachcarter/Projects/superpowers/systems/game/plugins/extra/tweenjs] `npm run build` exited with status code 1
npm ERR! Darwin 15.0.0
npm ERR! argv "node" "/usr/local/bin/npm" "run" "build"
npm ERR! node v0.12.7
npm ERR! npm v3.5.3
npm ERR! code ELIFECYCLE
npm ERR! superpowers@0.19.0 build: `node scripts/build.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the superpowers@0.19.0 build script 'node scripts/build.js'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the superpowers package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node scripts/build.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs superpowers
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls superpowers
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /Users/zachcarter/Projects/superpowers/npm-debug.log
V-97YG3QD:superpowers (master) $
@zacharycarter
Copy link
Author

zacharycarter commented Jan 23, 2016

V-97YG3QD:superpowers (master) $ vi npm-debug.log

0 info it worked if it ends with ok
1 verbose cli [ 'node', '/usr/local/bin/npm', 'run', 'build' ]
2 info using npm@3.5.3
3 info using node@v0.12.7
4 verbose node symlink /usr/local/bin/node
5 verbose run-script [ 'prebuild', 'build', 'postbuild' ]
6 info lifecycle superpowers@0.19.0prebuild: superpowers@0.19.0
7 silly lifecycle superpowers@0.19.0
prebuild: no script for prebuild, continuing
8 info lifecycle superpowers@0.19.0build: superpowers@0.19.0
9 verbose lifecycle superpowers@0.19.0
build: unsafe-perm in lifecycle true
10 verbose lifecycle superpowers@0.19.0build: PATH: /usr/local/lib/node_modules/npm/bin/node-gyp-bin:/Users/zachcarter/Projects/superpowers/node_modules/.bin:/Library/Frameworks/Python.framework/Versions/2.7/bin:/opt/local/bin:/opt/local/sbin:/Users/zachcarter/.rvm/gems/ruby-2.0.0-p576@dips/bin:/Users/zachcarter/.rvm/gems/ruby-2.0.0-p576@global/bin:/Users/zachcarter/.rvm/rubies/ruby-2.0.0-p576/bin:/Users/zachcarter/.sdkman/groovy/current/bin:/Users/zachcarter/.sdkman/grails/current/bin:/Users/zachcarter/.sdkman/gradle/current/bin:/usr/local/heroku/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin:/usr/local/go/bin:/Users/zachcarter/.rvm/bin:/Users/zachcarter/Projects/Nim/bin:/Users/zachcarter/.nimble/bin
11 verbose lifecycle superpowers@0.19.0
build: CWD: /Users/zachcarter/Projects/superpowers
12 silly lifecycle superpowers@0.19.0build: Args: [ '-c', 'node scripts/build.js' ]
13 silly lifecycle superpowers@0.19.0
build: Returned: code: 1 signal: null
14 info lifecycle superpowers@0.19.0~build: Failed to exec build script
15 verbose stack Error: superpowers@0.19.0 build: node scripts/build.js
15 verbose stack Exit status 1
15 verbose stack at EventEmitter. (/usr/local/lib/node_modules/npm/lib/utils/lifecycle.js:232:16)
15 verbose stack at EventEmitter.emit (events.js:110:17)
15 verbose stack at ChildProcess. (/usr/local/lib/node_modules/npm/lib/utils/spawn.js:24:14)
15 verbose stack at ChildProcess.emit (events.js:110:17)
15 verbose stack at maybeClose (child_process.js:1015:16)
15 verbose stack at Process.ChildProcess._handle.onexit (child_process.js:1087:5)
16 verbose pkgid superpowers@0.19.0
17 verbose cwd /Users/zachcarter/Projects/superpowers
18 error Darwin 15.0.0
19 error argv "node" "/usr/local/bin/npm" "run" "build"
20 error node v0.12.7
21 error npm v3.5.3
22 error code ELIFECYCLE
23 error superpowers@0.19.0 build: node scripts/build.js
23 error Exit status 1
24 error Failed at the superpowers@0.19.0 build script 'node scripts/build.js'.
24 error Make sure you have the latest version of node.js and npm installed.
24 error If you do, this is most likely a problem with the superpowers package,
24 error not with npm itself.
24 error Tell the author that this fails on your system:
24 error node scripts/build.js
24 error You can get information on how to open an issue for this project with:
24 error npm bugs superpowers
24 error Or if that isn't available, you can get their info via:
24 error npm owner ls superpowers
24 error There is likely additional logging output above.
25 verbose exit [ 1, true ]

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment