Skip to content

Instantly share code, notes, and snippets.

🏠
Working from home

Darmawan Zulkifli darmawan01

🏠
Working from home
Block or report user

Report or block darmawan01

Hide content and notifications from this user.

Learn more about blocking users

Contact Support about this user’s behavior.

Learn more about reporting abuse

Report abuse
View GitHub Profile
View notes.md

DUMP POSTGRES IN DOCKER

docker exec -t oa-monolithic_db_1 pg_dumpall -c -U oa > dump_`date +%d-%m-%Y"_"%H_%M_%S`.sql
View redisPubSubExample.go
package main
import (
"log"
"net/http"
"sync"
"github.com/garyburd/redigo/redis"
"github.com/gorilla/websocket"
uuid "github.com/satori/go.uuid"
@darmawan01
darmawan01 / DateExtension.kt
Created Mar 2, 2019 — forked from maiconhellmann/DateExtension.kt
Date extensions wrote in Kotlin
View DateExtension.kt
import java.text.SimpleDateFormat
import java.util.*
/**
* Pattern: yyyy-MM-dd HH:mm:ss
*/
fun Date.formatToServerDateTimeDefaults(): String{
val sdf= SimpleDateFormat("yyyy-MM-dd HH:mm:ss", Locale.getDefault())
return sdf.format(this)
@darmawan01
darmawan01 / docker-help.md
Created Dec 31, 2018 — forked from bradtraversy/docker-help.md
Docker Commands, Help & Tips
View docker-help.md

Docker Commands, Help & Tips

Show commands & management commands

$ docker

Docker version info

@darmawan01
darmawan01 / php.ini
Created Feb 6, 2018 — forked from ardianta/php.ini
Konfigurasi server PHP saya di Xubuntu 15.10
View php.ini
[PHP]
;;;;;;;;;;;;;;;;;;;
; About php.ini ;
;;;;;;;;;;;;;;;;;;;
; PHP's initialization file, generally called php.ini, is responsible for
; configuring many of the aspects of PHP's behavior.
; PHP attempts to find and load this configuration from a number of locations.
; The following is a summary of its search order:
@darmawan01
darmawan01 / laravel-5-4-php-ext-requirements.md
Created Jan 5, 2018 — forked from jpalala/laravel-5-4-php-ext-requirements.md
Laravel 5.3 or 5.4 PHP modules requireed for Ubuntu and Centos
View laravel-5-4-php-ext-requirements.md

Laravel docs says the following is needed

  • PHP >= 5.6.4
  • OpenSSL PHP Extension
  • PDO PHP Extension
  • Mbstring PHP Extension
  • Tokenizer PHP Extension
  • XML PHP Extension

Many packages need curl, so I suggest adding php-curl and uploading and manipulating images require the gd library, php-gd

@darmawan01
darmawan01 / 0_python_email.md
Created Jan 3, 2018 — forked from nickoala/0_python_email.md
Use Python to send and receive emails
View 0_python_email.md

Use Python to:

  • send a plain text email
  • send an email with attachment
  • receive and filter emails according to some criteria
You can’t perform that action at this time.