Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
git: how to solve "SSLRead() return error -9806" in OSX using brew
$ brew remove git
$ brew remove curl
$ brew install openssl
$ brew install --with-openssl curl
$ brew install --with-brewed-curl --with-brewed-openssl git
@alexanderkhitev
Copy link

Didn't work for me too

@nicolasmlv
Copy link

maybe your git cloud provider is unavailable. (I got this error today, Bitbucket was down)

@chmiiller
Copy link

Me too, bit bucket SSH still down =/
https://status.bitbucket.org

@gdvalderrama
Copy link

The following warnings appear:
Warning: git: --with-brewed-openssl was deprecated; using --with-openssl instead!
Warning: git: --with-brewed-curl was deprecated; using --with-curl instead!

So you should use brew install --with-curl --with-openssl git in the last step instead

@BirkhoffLee
Copy link

The Homebrew team has recently removed all install options for the cURL formula, which means you will not be able to do brew install curl --with-openssl now. Instead, do brew install curl-openssl. Make sure to uninstall the old one with brew uninstall curl first.

@rdwivedi
Copy link

brew install --with-curl --with-openssl git this did not work for me. I had to do plain vanilla brew install git. this worked.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment