Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
rbenv recipe to install 2.1.0 with railsexpress patch
build_package_reconfigure() {
test -f configure || autoconf
}
build_package_patch_ruby_railsexpress() {
fetch_git rvm-patchsets git://github.com/skaes/rvm-patchsets.git master
patch -p1 < rvm-patchsets/patches/ruby/2.1.0/railsexpress/01-current-2.1.1-fixes.patch
patch -p1 < rvm-patchsets/patches/ruby/2.1.0/railsexpress/02-zero-broken-tests.patch
patch -p1 < rvm-patchsets/patches/ruby/2.1.0/railsexpress/03-improve-gc-stats.patch
patch -p1 < rvm-patchsets/patches/ruby/2.1.0/railsexpress/04-display-more-detailed-stack-trace.patch
patch -p1 < rvm-patchsets/patches/ruby/2.1.0/railsexpress/05-show-full-backtrace-on-stack-overflow.patch
patch -p1 < rvm-patchsets/patches/ruby/2.1.0/railsexpress/06-fix-missing-c-return-event.patch
patch -p1 < rvm-patchsets/patches/ruby/2.1.0/railsexpress/07-backport-006e66b6680f60adfb434ee7397f0dbc77de7873.patch
patch -p1 < rvm-patchsets/patches/ruby/2.1.0/railsexpress/08-funny-falcon-stc-density.patch
patch -p1 < rvm-patchsets/patches/ruby/2.1.0/railsexpress/09-funny-falcon-stc-pool-allocation.patch
patch -p1 < rvm-patchsets/patches/ruby/2.1.0/railsexpress/10-aman-opt-aset-aref-str.patch
patch -p1 < rvm-patchsets/patches/ruby/2.1.0/railsexpress/11-funny-falcon-method-cache.patch
patch -p1 < rvm-patchsets/patches/ruby/2.1.0/railsexpress/12-backport-r44370.patch
}
install_package "openssl-1.0.1e" "https://www.openssl.org/source/openssl-1.0.1e.tar.gz#66bf6f10f060d561929de96f9dfe5b8c" mac_openssl --if has_broken_mac_openssl
install_package "ruby-2_1_0" "https://github.com/ruby/ruby/archive/v2_1_0.tar.gz#994a6092845d681b440ef3c8fe29a6d2" reconfigure patch_ruby_railsexpress ldflags_dirs standard verify_openssl
#!/usr/bin/env bash
if command -v brew > /dev/null
then
if brew --prefix openssl > /dev/null
then
CONFIGURE_OPTS="$CONFIGURE_OPTS --with-openssl-dir=`brew --prefix openssl`"
fi
if brew --prefix readline > /dev/null
then
CONFIGURE_OPTS="$CONFIGURE_OPTS --with-readline-dir=`brew --prefix readline`"
fi
fi
echo "==> Installing ruby version:"
rbenv install ./2.1.0-railsexpress
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.