Create a gist now

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Janus install problem
rake --trace
(in /Users/jpinnix/.vim)
** Invoke default (first_time)
** Invoke ack.vim (first_time)
** Execute ack.vim
****************************************
* Installing ack.vim *
****************************************
** Invoke ack.vim:install (first_time)
** Invoke ack.vim:pull (first_time)
** Invoke /Users/jpinnix/.vim/tmp/ack.vim (first_time, not_needed)
** Invoke tmp (first_time, not_needed)
** Execute ack.vim:pull
git pull
Already up-to-date.
** Invoke after (first_time, not_needed)
** Invoke autoload (first_time, not_needed)
** Invoke doc (first_time, not_needed)
** Invoke plugin (first_time, not_needed)
** Invoke ruby (first_time, not_needed)
** Invoke snippets (first_time, not_needed)
** Invoke syntax (first_time, not_needed)
** Invoke ftdetect (first_time, not_needed)
** Invoke ftplugin (first_time, not_needed)
** Invoke colors (first_time, not_needed)
** Invoke indent (first_time, not_needed)
** Execute ack.vim:install
rake install
(in /Users/jpinnix/.vim/tmp/ack.vim)
Copied doc/ack.txt to /Users/jpinnix/.vim/doc/ack.txt
Copied plugin/ack.vim to /Users/jpinnix/.vim/plugin/ack.vim
** Invoke color-sampler (first_time)
** Execute color-sampler
****************************************
* Installing color-sampler *
****************************************
** Invoke color-sampler:install (first_time)
** Invoke color-sampler:pull (first_time)
** Invoke /Users/jpinnix/.vim/tmp/color-sampler (first_time)
** Invoke tmp (not_needed)
** Execute /Users/jpinnix/.vim/tmp/color-sampler
rake aborted!
unable to determine script type
/Users/jpinnix/.vim/Rakefile:26:in `vim_plugin_task'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `call'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `execute'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `each'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `execute'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:597:in `invoke_with_call_chain'
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:607:in `invoke_prerequisites'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `each'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `invoke_prerequisites'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:596:in `invoke_with_call_chain'
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:607:in `invoke_prerequisites'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `each'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `invoke_prerequisites'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:596:in `invoke_with_call_chain'
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:583:in `invoke'
/Users/jpinnix/.vim/Rakefile:118:in `vim_plugin_task'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `call'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `execute'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `each'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `execute'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:597:in `invoke_with_call_chain'
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:607:in `invoke_prerequisites'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `each'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `invoke_prerequisites'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:596:in `invoke_with_call_chain'
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:583:in `invoke'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:2051:in `invoke_task'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `top_level'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `each'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `top_level'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:2023:in `top_level'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:2001:in `run'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
/Library/Ruby/Gems/1.8/gems/rake-0.8.7/bin/rake:31
/usr/bin/rake:19:in `load'
/usr/bin/rake:19
@insaneirish

This comment has been minimized.

Show comment
Hide comment
@insaneirish

insaneirish Feb 11, 2011

Having the same identical problem.

Having the same identical problem.

@mikaa123

This comment has been minimized.

Show comment
Hide comment
@mikaa123

mikaa123 Feb 11, 2011

Me too, I can't get to install Janus...

Me too, I can't get to install Janus...

@beerlington

This comment has been minimized.

Show comment
Hide comment
@beerlington

beerlington Feb 11, 2011

Got this error too, seems like it's an issue with vim.org and some database issues... hopefully just temporary. If you comment out the vim.org plugins in the Rakefile, it will at least install for now

Got this error too, seems like it's an issue with vim.org and some database issues... hopefully just temporary. If you comment out the vim.org plugins in the Rakefile, it will at least install for now

@viktorkelemen

This comment has been minimized.

Show comment
Hide comment
@viktorkelemen

viktorkelemen Feb 11, 2011

it seems like the vim.org/scripts has connection problems.
so i replaced the http://www.vim.org/scripts/ links with a mirror, git://github.com/vim-scripts/
https://github.com/yikulju/janus/commit/03a3952669c72e43a31a7efe030a4254dedbb200

it seems like the vim.org/scripts has connection problems.
so i replaced the http://www.vim.org/scripts/ links with a mirror, git://github.com/vim-scripts/
https://github.com/yikulju/janus/commit/03a3952669c72e43a31a7efe030a4254dedbb200

@teoruiz

This comment has been minimized.

Show comment
Hide comment
@teoruiz

teoruiz Feb 11, 2011

Thanks @yikulju !

teoruiz commented Feb 11, 2011

Thanks @yikulju !

@jpinnix

This comment has been minimized.

Show comment
Hide comment
@jpinnix

jpinnix Feb 11, 2011

Thanks so much @yikulju!!

Owner

jpinnix commented Feb 11, 2011

Thanks so much @yikulju!!

@kallepersson

This comment has been minimized.

Show comment
Hide comment
@kallepersson

kallepersson Feb 11, 2011

thanks @yikulju!

thanks @yikulju!

@jameydavis

This comment has been minimized.

Show comment
Hide comment
@jameydavis

jameydavis Feb 12, 2011

Thanks so much for this @yikulju :)

Thanks so much for this @yikulju :)

@jtinfors

This comment has been minimized.

Show comment
Hide comment
@jtinfors

jtinfors Feb 13, 2011

excellent!

excellent!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment