Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Build termite terminal and vte/vte-ng on Ubuntu
# VTE
apt-get install autoconf libglib2.0-dev gtk-doc-tools libpcre2-dev libgirepository1.0-dev gperf libvte-2.91-dev libvte-dev valac unzip
wget https://github.com/thestinger/vte-ng/archive/0.46.0.a.zip
unzip 0.46.0.a.zip
rm 0.46.0.a.zip
cd vte-ng-0.46.0.a
bash autogen.sh
make && make install
cd ~
rm -rf vte-ng-0.46.0.a/
# TERMITE
apt install git
git clone --recursive https://github.com/thestinger/termite.git
cd termite/
make && make install
cd ~
rm -rf termite/
# TLP for Thinkpad x230
# apt install tlp tlp-rdw tp-smapi-dkms acpi-call-dkms smartmontools linux-tools-common
# apt install powertop
@jchook

This comment has been minimized.

Copy link

commented Sep 22, 2017

Worked perfectly, thanks!

@bhediathewolf

This comment has been minimized.

Copy link

commented May 23, 2018

Had issues with vte. There is a binary for it though, libvte-2.90-9, which was enough. So, now, it works on Deepin 15.5, too. Thanks mate.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.