Create a gist now

Instantly share code, notes, and snippets.

What would you like to do?
Something is erroring out...
⚡ movienight (jruby)$ gem -v
⚡ movienight (jruby)$ gem update --system
Updating RubyGems
Updating rubygems-update
Successfully installed rubygems-update-1.4.1
Updating RubyGems to 1.4.1
Installing RubyGems 1.4.1
/Users/matt/.rvm/gems/jruby-1.5.6/gems/rubygems-update-1.4.1/lib/rubygems/gem_runner.rb:14: undefined method `load_env_plugins' for Gem:Module (NoMethodError)
from /Users/matt/.rvm/gems/jruby-1.5.6/gems/rubygems-update-1.4.1/lib/rubygems/gem_runner.rb:31:in `require'
from /Users/matt/.rvm/rubies/jruby-1.5.6/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
from setup.rb:25
RubyGems system software updated
⚡ movienight (jruby)$ gem -v
⚡ movienight (jruby)$ which gem

I get the same error with JRuby


mattyoho commented Jan 5, 2011

I dropped into #rubygems on IRC and Eric Hodel recommended to manually run gem install rubygems-update -v 1.3.7; update_rubygems _1.3.7_ to get up to 1.3.7 from 1.3.6 (despite Nick Sieger's recommendation against it in #jruby). I did that and it worked, which solved my root problem.

My original problem was that a bundle install would fail if "gem 'nokogiri', ''" was in the Gemfile, because of something where RubyGems 1.3.6 + Bundler didn't like the quartet of version numbers. Going to 1.3.7 fixed this.

Eric stated you could then go up to 1.4.0 => 1.4.1 with RubyGems, but I don't have the need to do so and am sticking with 1.3.7 for now.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment