I get the same error with JRuby
I dropped into #rubygems on IRC and Eric Hodel recommended to manually run gem install rubygems-update -v 1.3.7; update_rubygems _1.3.7_ to get up to 1.3.7 from 1.3.6 (despite Nick Sieger's recommendation against it in #jruby). I did that and it worked, which solved my root problem.
gem install rubygems-update -v 1.3.7; update_rubygems _1.3.7_
My original problem was that a bundle install would fail if "gem 'nokogiri', '18.104.22.168'" was in the Gemfile, because of something where RubyGems 1.3.6 + Bundler didn't like the quartet of version numbers. Going to 1.3.7 fixed this.
Eric stated you could then go up to 1.4.0 => 1.4.1 with RubyGems, but I don't have the need to do so and am sticking with 1.3.7 for now.