Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Bundler has been giving me these errors (across completely different repos) for a while now and I really need to figure out what's causing this. Anybody have a clue?
Bundler gave the error "Could not find rake-10.1.0 in any of the sources" while processing "/Users/olivierlacan/Development/envylabs/codeschool/iOS7Course/Gemfile". Perhaps you forgot to run "bundle install"?
Bundler gave the error "Could not find libv8-3.11.8.13 in any of the sources" while processing "/Users/olivierlacan/Development/envylabs/codeschool/TryDevTools/Gemfile". Perhaps you forgot to run "bundle install"?
Bundler gave the error "Could not find gem 'jquery-rails (~> 2.0.1) ruby' in the gems available on this machine." while processing "/Users/olivierlacan/Development/envylabs/codeschool/BackboneCourse/Gemfile". Perhaps you forgot to run "bundle install"?
Bundler gave the error "Could not find libv8-3.11.8.17 in any of the sources" while processing "/Users/olivierlacan/Development/envylabs/codeschool/FrontEndFormationsCourse/Gemfile". Perhaps you forgot to run "bundle install"?
Bundler gave the error "Could not find libv8-3.11.8.13 in any of the sources" while processing "/Users/olivierlacan/Development/envylabs/codeschool/NodeJSCourse/Gemfile". Perhaps you forgot to run "bundle install"?
Bundler gave the error "Could not find libv8-3.11.8.13 in any of the sources" while processing "/Users/olivierlacan/Development/envylabs/codeschool/ios_operation_maps/Gemfile". Perhaps you forgot to run "bundle install"?
@olivierlacan

This comment has been minimized.

Copy link
Owner Author

commented Dec 24, 2013

Important: this output is produced at the end of a bundle install command inside of a completely different repo than any of the paths the errors are stemming from.

@olivierlacan

This comment has been minimized.

Copy link
Owner Author

commented Dec 24, 2013

Oh, and to answer a question from @schneems, the only gem that is actually being show as installed in the repo where bundle install is run is jquery-rails. Here's the bundle install output that precedes the output above:

$ bundle install
Fetching gem metadata from http://rubygems.org/.........
Fetching additional metadata from http://rubygems.org/..
Could not load the bundler gem for Ruby version 2.0.0-p353.
Installing rake (0.9.2.2)
Installing multi_json (1.0.3)
Installing activesupport (3.1.3)
Installing builder (3.0.0)
Installing i18n (0.6.0)
Installing activemodel (3.1.3)
Could not load the bundler gem for Ruby version 2.0.0-p353.
Installing erubis (2.7.0)
Could not load the bundler gem for Ruby version 2.0.0-p353.
Installing rack (1.3.5)
Installing rack-cache (1.1)
Installing rack-mount (0.8.3)
Installing rack-test (0.6.1)
Installing hike (1.2.1)
Could not load the bundler gem for Ruby version 2.0.0-p353.
Installing tilt (1.3.3)
Installing sprockets (2.0.3)
Installing actionpack (3.1.3)
Installing mime-types (1.17.2)
Installing polyglot (0.3.3)
Could not load the bundler gem for Ruby version 2.0.0-p353.
Installing treetop (1.4.10)
Installing mail (2.3.0)
Installing actionmailer (3.1.3)
Installing arel (2.2.1)
Installing tzinfo (0.3.31)
Installing activerecord (3.1.3)
Installing activeresource (3.1.3)
Installing ansi (1.4.1)
Installing bcrypt-ruby (3.0.1)
Installing coffee-script-source (1.1.3)
Installing execjs (1.2.9)
Installing coffee-script (2.2.0)
Installing rack-ssl (1.3.2)
Installing json (1.6.1)
Could not load the bundler gem for Ruby version 2.0.0-p353.
Installing rdoc (3.11)
Could not load the bundler gem for Ruby version 2.0.0-p353.
Installing thor (0.14.6)
Installing railties (3.1.3)
Installing coffee-rails (3.1.1)
Installing orm_adapter (0.0.5)
Installing warden (1.1.0)
Installing devise (1.5.0)
Could not load the bundler gem for Ruby version 2.0.0-p353.
Installing haml (3.1.3)
Installing haml-rails (0.3.4)
Installing jquery-rails (1.0.19)
Installing pg (0.11.0)
Using bundler (1.5.0.rc.1)
Could not load the bundler gem for Ruby version 2.0.0-p353.
Installing rails (3.1.3)
Could not load the bundler gem for Ruby version 2.0.0-p353.
Installing rdiscount (1.6.8)
Could not load the bundler gem for Ruby version 2.0.0-p353.
Installing sass (3.1.10)
Installing sass-rails (3.1.5)
Installing simple_form (1.5.2)
Installing sqlite3 (1.3.4)
Could not load the bundler gem for Ruby version 2.0.0-p353.
Installing turn (0.8.3)
Installing uglifier (1.1.0)
Your bundle is complete!
It was installed into ./.bundle
Post-install message from rdoc:
Depending on your version of ruby, you may need to install ruby rdoc/ri data:

<= 1.8.6 : unsupported
 = 1.8.7 : gem install rdoc-data; rdoc-data --install
 = 1.9.1 : gem install rdoc-data; rdoc-data --install
>= 1.9.2 : nothing to do! Yay!
@hone

This comment has been minimized.

Copy link

commented Dec 24, 2013

Does it come up when you use 1.5.0.rc.2? (i'm thinking concurrency bug) 1.3.5?

@stringsn88keys

This comment has been minimized.

Copy link

commented Apr 23, 2014

This started happening to me after I had uninstalled a ruby version via rbenv and reinstalled. All projects using that ruby version were mentioned in the error until I did a bundle install in each of those projects.

@jadeforrest

This comment has been minimized.

Copy link

commented Feb 13, 2015

@stringsn88keys you are my hero. This was so annoying.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.