Skip to content

Instantly share code, notes, and snippets.

@rusrushal13
Created Mar 7, 2017
Embed
What would you like to do?
(zenodo) rushal@rushal-Lenovo-B560:~/src/zenodo$ sudo pip install -r requirements.txt --src ~/src/ --pre --upgrade
The directory '/home/rushal/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/rushal/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Obtaining zenodo-migrator from git+https://github.com/zenodo/zenodo-migrator.git#egg=zenodo-migrator (from -r requirements.txt (line 29))
Updating /home/rushal/src/zenodo-migrator clone
Obtaining invenio-migrator from git+https://github.com/lnielsen/invenio-migrator.git@#egg=invenio-migrator (from -r requirements.txt (line 30))
Updating /home/rushal/src/invenio-migrator clone
Requirement already up-to-date: alabaster==0.7.9 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 33))
Requirement already up-to-date: alembic==0.8.8 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 34))
Requirement already up-to-date: amqp==1.4.9 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 35))
Requirement already up-to-date: anyjson==0.3.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 36))
Requirement already up-to-date: apipkg==1.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 37))
Requirement already up-to-date: arrow==0.8.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 38))
Requirement already up-to-date: Babel==2.3.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 39))
Requirement already up-to-date: backports.shutil-get-terminal-size==1.0.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 40))
Requirement already up-to-date: billiard==3.3.0.23 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 41))
Requirement already up-to-date: binaryornot==0.4.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 42))
Requirement already up-to-date: bleach==1.5.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 43))
Requirement already up-to-date: blinker==1.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 44))
Requirement already up-to-date: cairocffi==0.7.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 45))
Requirement already up-to-date: CairoSVG==1.0.22 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 46))
Requirement already up-to-date: cchardet==1.1.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 47))
Requirement already up-to-date: celery==3.1.25 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 48))
Requirement already up-to-date: cffi==1.9.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 49))
Requirement already up-to-date: chardet==2.3.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 50))
Requirement already up-to-date: check-manifest==0.34 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 51))
Requirement already up-to-date: citeproc-py==0.3.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 52))
Requirement already up-to-date: citeproc-py-styles==0.1.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 53))
Requirement already up-to-date: click==6.6 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 54))
Requirement already up-to-date: configparser==3.5.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 55))
Requirement already up-to-date: cookiecutter==1.4.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 56))
Requirement already up-to-date: coverage==4.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 57))
Requirement already up-to-date: cryptography==1.5.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 58))
Requirement already up-to-date: datacite==0.3.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 59))
Requirement already up-to-date: dcxml==0.1.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 60))
Requirement already up-to-date: decorator==4.0.10 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 61))
Requirement already up-to-date: dictdiffer==0.6.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 62))
Requirement already up-to-date: docutils==0.12 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 63))
Requirement already up-to-date: dojson==1.2.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 64))
Requirement already up-to-date: elasticsearch==2.4.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 65))
Requirement already up-to-date: elasticsearch-dsl==2.2.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 66))
Requirement already up-to-date: entrypoints==0.2.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 67))
Requirement already up-to-date: execnet==1.4.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 68))
Requirement already up-to-date: Flask==0.11.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 69))
Requirement already up-to-date: Flask-Admin==1.4.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 70))
Requirement already up-to-date: Flask-Alembic==2.0.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 71))
Requirement already up-to-date: Flask-Assets==0.12 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 72))
Requirement already up-to-date: Flask-BabelEx==0.9.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 73))
Requirement already up-to-date: Flask-Breadcrumbs==0.4.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 74))
Requirement already up-to-date: Flask-Cache==0.13.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 75))
Requirement already up-to-date: Flask-CeleryExt==0.2.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 76))
Requirement already up-to-date: Flask-Collect==1.2.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 77))
Requirement already up-to-date: Flask-Cors==3.0.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 78))
Requirement already up-to-date: Flask-DebugToolbar==0.10.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 79))
Requirement already up-to-date: Flask-Konch==1.1.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 80))
Requirement already up-to-date: Flask-KVSession==0.6.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 81))
Requirement already up-to-date: Flask-Limiter==0.9.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 82))
Requirement already up-to-date: Flask-Login==0.4.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 83))
Requirement already up-to-date: Flask-Mail==0.9.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 84))
Requirement already up-to-date: Flask-Menu==0.5.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 85))
Requirement already up-to-date: Flask-OAuthlib==0.9.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 86))
Requirement already up-to-date: Flask-Principal==0.4.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 87))
Requirement already up-to-date: Flask-Security-Fork==1.8.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 88))
Requirement already up-to-date: Flask-SQLAlchemy==2.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 89))
Requirement already up-to-date: Flask-WTF==0.13.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 90))
Requirement already up-to-date: fs==0.5.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 91))
Requirement already up-to-date: ftfy==4.3.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 92))
Requirement already up-to-date: funcsigs==1.0.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 93))
Requirement already up-to-date: future==0.16.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 94))
Requirement already up-to-date: github3.py==1.0.0a4 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 95))
Requirement already up-to-date: html5lib==0.9999999 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 96))
Requirement already up-to-date: humanize==0.5.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 97))
Requirement already up-to-date: idna==2.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 98))
Requirement already up-to-date: IDUtils==0.2.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 99))
Requirement already up-to-date: imagesize==0.7.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 100))
Requirement already up-to-date: infinity==1.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 101))
Requirement already up-to-date: intervals==0.8.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 102))
Requirement already up-to-date: invenio-access==1.0.0a11 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 103))
Requirement already up-to-date: invenio-accounts==1.0.0b1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 104))
Requirement already up-to-date: invenio-admin==1.0.0a3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 105))
Requirement already up-to-date: invenio-assets==1.0.0b4 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 106))
Requirement already up-to-date: invenio-base==1.0.0a14 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 107))
Requirement already up-to-date: invenio-celery==1.0.0b1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 108))
Requirement already up-to-date: invenio-communities==1.0.0a13 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 109))
Requirement already up-to-date: invenio-config==1.0.0b1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 110))
Requirement already up-to-date: invenio-csl-rest==1.0.0a1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 111))
Requirement already up-to-date: invenio-db==1.0.0b3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 112))
Requirement already up-to-date: invenio-deposit==1.0.0a7 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 113))
Requirement already up-to-date: invenio-files-rest==1.0.0a14 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 114))
Requirement already up-to-date: invenio-formatter==1.0.0a2 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 115))
Requirement already up-to-date: invenio-github==1.0.0a10 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 116))
Requirement already up-to-date: invenio-i18n==1.0.0b1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 117))
Requirement already up-to-date: invenio-indexer==1.0.0a8 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 118))
Requirement already up-to-date: invenio-jsonschemas==1.0.0a3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 119))
Requirement already up-to-date: invenio-logging==1.0.0a3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 120))
Requirement already up-to-date: invenio-mail==1.0.0a5 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 121))
Requirement already up-to-date: invenio-marc21==1.0.0a3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 122))
Requirement already up-to-date: invenio-oaiserver==1.0.0a12 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 123))
Requirement already up-to-date: invenio-oauth2server==1.0.0a14 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 124))
Requirement already up-to-date: invenio-oauthclient==1.0.0a12 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 125))
Requirement already up-to-date: invenio-openaire==1.0.0a7 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 126))
Requirement already up-to-date: invenio-opendefinition==1.0.0a3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 127))
Requirement already up-to-date: invenio-pages==1.0.0a3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 128))
Requirement already up-to-date: invenio-pidstore==1.0.0b1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 129))
Requirement already up-to-date: invenio-previewer==1.0.0a10 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 130))
Requirement already up-to-date: invenio-query-parser==0.6.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 131))
Requirement already up-to-date: invenio-records==1.0.0b1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 132))
Requirement already up-to-date: invenio-records-files==1.0.0a8 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 133))
Requirement already up-to-date: invenio-records-rest==1.0.0a17 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 134))
Requirement already up-to-date: invenio-records-ui==1.0.0a8 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 135))
Requirement already up-to-date: invenio-rest==1.0.0a10 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 136))
Requirement already up-to-date: invenio-search==1.0.0a9 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 137))
Requirement already up-to-date: invenio-search-ui==1.0.0a5 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 138))
Requirement already up-to-date: invenio-sipstore==1.0.0a3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 139))
Requirement already up-to-date: invenio-theme==1.0.0a14 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 140))
Requirement already up-to-date: invenio-userprofiles==1.0.0a9 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 141))
Requirement already up-to-date: invenio-webhooks==1.0.0a4 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 142))
Requirement already up-to-date: ipython==5.1.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 143))
Requirement already up-to-date: ipython-genutils==0.1.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 144))
Collecting isbnid==0.4.2.1 (from -r requirements.txt (line 145))
Downloading isbnid-0.4.2.1.tar.gz
Requested isbnid==0.4.2.1 from https://pypi.python.org/packages/67/58/d77a797692aa74294bad8e82e4ffc28c9abeb5173288a079ee54daef6d63/isbnid-0.4.2.1.tar.gz#md5=0779cc63b7edc12f6a745735951333c7 (from -r requirements.txt (line 145)), but installing version 0.4.2
Requirement already up-to-date: isort==4.2.5 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 146))
Requirement already up-to-date: itsdangerous==0.24 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 147))
Requirement already up-to-date: Jinja2==2.8 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 148))
Requirement already up-to-date: jinja2-time==0.2.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 149))
Requirement already up-to-date: jsmin==2.2.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 150))
Requirement already up-to-date: jsonpatch==1.14 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 151))
Requirement already up-to-date: jsonpointer==1.10 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 152))
Requirement already up-to-date: jsonref==0.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 153))
Requirement already up-to-date: jsonresolver==0.2.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 154))
Requirement already up-to-date: jsonschema==2.5.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 155))
Requirement already up-to-date: jupyter-core==4.2.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 156))
Requirement already up-to-date: kombu==3.0.37 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 157))
Requirement already up-to-date: Konch==2.2.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 158))
Requirement already up-to-date: limits==1.2.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 159))
Requirement already up-to-date: lxml==3.6.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 160))
Requirement already up-to-date: Mako==1.0.6 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 161))
Requirement already up-to-date: MarkupSafe==0.23 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 162))
Requirement already up-to-date: marshmallow==2.10.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 163))
Requirement already up-to-date: mistune==0.7.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 164))
Requirement already up-to-date: mock==2.0.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 165))
Requirement already up-to-date: msgpack-python==0.4.8 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 166))
Requirement already up-to-date: nbconvert==4.2.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 167))
Requirement already up-to-date: nbformat==4.1.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 168))
Requirement already up-to-date: ndg-httpsclient==0.4.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 169))
Requirement already up-to-date: node-semver==0.1.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 170))
Requirement already up-to-date: oauthlib==1.1.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 171))
Requirement already up-to-date: ordereddict==1.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 172))
Requirement already up-to-date: passlib==1.6.5 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 173))
Requirement already up-to-date: pathlib2==2.1.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 174))
Requirement already up-to-date: pbr==1.10.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 175))
Requirement already up-to-date: pep8==1.7.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 176))
Requirement already up-to-date: pexpect==4.2.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 177))
Requirement already up-to-date: pickleshare==0.7.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 178))
Requirement already up-to-date: Pillow==3.4.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 179))
Requirement already up-to-date: pluggy==0.4.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 180))
Requirement already up-to-date: poyo==0.4.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 181))
Requirement already up-to-date: prompt-toolkit==1.0.9 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 182))
Requirement already up-to-date: psycopg2==2.6.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 183))
Requirement already up-to-date: ptyprocess==0.5.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 184))
Requirement already up-to-date: py==1.4.31 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 185))
Requirement already up-to-date: pyasn1==0.1.9 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 186))
Requirement already up-to-date: pycparser==2.17 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 187))
Requirement already up-to-date: pydocstyle==1.1.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 188))
Requirement already up-to-date: Pygments==2.1.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 189))
Requirement already up-to-date: pyOpenSSL==16.2.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 190))
Requirement already up-to-date: pyPEG2==2.15.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 191))
Requirement already up-to-date: pytest==3.0.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 192))
Requirement already up-to-date: pytest-cache==1.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 193))
Requirement already up-to-date: pytest-cov==2.4.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 194))
Requirement already up-to-date: pytest-flask==0.10.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 195))
Requirement already up-to-date: pytest-pep8==1.0.6 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 196))
Requirement already up-to-date: python-dateutil==2.6.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 197))
Requirement already up-to-date: python-editor==1.0.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 198))
Requirement already up-to-date: python-slugify==1.2.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 199))
Requirement already up-to-date: pytz==2016.7 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 200))
Requirement already up-to-date: raven==5.1.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 201))
Requirement already up-to-date: redis==2.10.5 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 202))
Requirement already up-to-date: requests==2.12.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 203))
Requirement already up-to-date: requests-oauthlib==0.7.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 204))
Requirement already up-to-date: selenium==2.52.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 205))
Requirement already up-to-date: Sickle==0.6.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 206))
Requirement already up-to-date: simplegeneric==0.8.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 207))
Requirement already up-to-date: simplejson==3.10.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 208))
Requirement already up-to-date: simplekv==0.10.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 209))
Requirement already up-to-date: six==1.10.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 210))
Requirement already up-to-date: snowballstemmer==1.2.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 211))
Requirement already up-to-date: speaklater==1.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 212))
Requirement already up-to-date: Sphinx==1.4.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 213))
Requirement already up-to-date: SQLAlchemy==1.1.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 214))
Requirement already up-to-date: SQLAlchemy-Continuum==1.2.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 215))
Requirement already up-to-date: SQLAlchemy-Utils==0.32.11 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 216))
Requirement already up-to-date: statsd==3.2.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 217))
Requirement already up-to-date: traitlets==4.3.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 218))
Requirement already up-to-date: Unidecode==0.4.19 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 219))
Requirement already up-to-date: uritemplate.py==1.0.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 220))
Requirement already up-to-date: uritools==2.0.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 221))
Requirement already up-to-date: urllib3==1.19.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 222))
Requirement already up-to-date: uwsgi==2.0.14 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 223))
Requirement already up-to-date: uwsgitop==0.9 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 224))
Requirement already up-to-date: validators==0.11.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 225))
Requirement already up-to-date: vine==1.1.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 226))
Requirement already up-to-date: wcwidth==0.1.7 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 227))
Requirement already up-to-date: webargs==1.4.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 228))
Requirement already up-to-date: webassets==0.12.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 229))
Requirement already up-to-date: Werkzeug==0.11.11 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 230))
Requirement already up-to-date: whichcraft==0.4.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 231))
Requirement already up-to-date: wsgi-statsd==0.3.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 232))
Requirement already up-to-date: WTForms==2.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 233))
Requirement already up-to-date: WTForms-Alchemy==0.16.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 234))
Requirement already up-to-date: WTForms-Components==0.10.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 235))
Requirement already up-to-date: zenodo-accessrequests==1.0.0a2 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 236))
Requirement already up-to-date: setuptools>=11.3 in /usr/local/lib/python2.7/dist-packages (from cryptography==1.5.3->-r requirements.txt (line 58))
Requirement already up-to-date: enum34 in /usr/local/lib/python2.7/dist-packages (from cryptography==1.5.3->-r requirements.txt (line 58))
Requirement already up-to-date: ipaddress in /usr/local/lib/python2.7/dist-packages (from cryptography==1.5.3->-r requirements.txt (line 58))
Requirement already up-to-date: ipaddr>=2.1.11; python_version == "2.7" in /usr/local/lib/python2.7/dist-packages (from invenio-accounts==1.0.0b1->-r requirements.txt (line 104))
Requirement already up-to-date: Flask-CLI>=0.2.1 in /usr/local/lib/python2.7/dist-packages (from invenio-records-rest==1.0.0a17->-r requirements.txt (line 134))
Requirement already up-to-date: functools32; python_version == "2.7" in /usr/local/lib/python2.7/dist-packages (from jsonschema==2.5.1->-r requirements.txt (line 155))
Collecting appdirs>=1.4.0 (from setuptools>=11.3->cryptography==1.5.3->-r requirements.txt (line 58))
Downloading appdirs-1.4.3-py2.py3-none-any.whl
Requirement already up-to-date: packaging>=16.8 in /usr/local/lib/python2.7/dist-packages (from setuptools>=11.3->cryptography==1.5.3->-r requirements.txt (line 58))
Requirement already up-to-date: pyparsing in /usr/local/lib/python2.7/dist-packages (from packaging>=16.8->setuptools>=11.3->cryptography==1.5.3->-r requirements.txt (line 58))
Installing collected packages: invenio-migrator, zenodo-migrator, isbnid, appdirs
Found existing installation: invenio-migrator 1.0.0a9.dev20160901
Can't uninstall 'invenio-migrator'. No files were found to uninstall.
Running setup.py develop for invenio-migrator
Found existing installation: zenodo-migrator 1.0.0.dev20150000
Can't uninstall 'zenodo-migrator'. No files were found to uninstall.
Running setup.py develop for zenodo-migrator
Found existing installation: isbnid 0.4.2
Uninstalling isbnid-0.4.2:
Successfully uninstalled isbnid-0.4.2
Running setup.py install for isbnid ... done
Found existing installation: appdirs 1.4.2
Uninstalling appdirs-1.4.2:
Successfully uninstalled appdirs-1.4.2
Rolling back uninstall of appdirs
Exception:
Traceback (most recent call last):
File "/usr/local/lib/python2.7/dist-packages/pip/basecommand.py", line 215, in main
status = self.run(options, args)
File "/usr/local/lib/python2.7/dist-packages/pip/commands/install.py", line 342, in run
prefix=options.prefix_path,
File "/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py", line 784, in install
**kwargs
File "/usr/local/lib/python2.7/dist-packages/pip/req/req_install.py", line 851, in install
self.move_wheel_files(self.source_dir, root=root, prefix=prefix)
File "/usr/local/lib/python2.7/dist-packages/pip/req/req_install.py", line 1064, in move_wheel_files
isolated=self.isolated,
File "/usr/local/lib/python2.7/dist-packages/pip/wheel.py", line 247, in move_wheel_files
prefix=prefix,
File "/usr/local/lib/python2.7/dist-packages/pip/locations.py", line 140, in distutils_scheme
d = Distribution(dist_args)
File "/usr/local/lib/python2.7/dist-packages/setuptools/dist.py", line 320, in __init__
_Distribution.__init__(self, attrs)
File "/usr/lib/python2.7/distutils/dist.py", line 287, in __init__
self.finalize_options()
File "/usr/local/lib/python2.7/dist-packages/setuptools/dist.py", line 386, in finalize_options
ep.require(installer=self.fetch_build_egg)
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2324, in require
items = working_set.resolve(reqs, env, installer, extras=self.extras)
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 862, in resolve
new_requirements = dist.requires(req.extras)[::-1]
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2568, in requires
dm = self._dep_map
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2815, in _dep_map
self.__dep_map = self._compute_dependencies()
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2824, in _compute_dependencies
for req in self._parsed_pkg_info.get_all('Requires-Dist') or []:
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2806, in _parsed_pkg_info
metadata = self.get_metadata(self.PKG_INFO)
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 1468, in get_metadata
value = self._get(self._fn(self.egg_info, name))
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 1577, in _get
with open(path, 'rb') as stream:
IOError: [Errno 2] No such file or directory: '/usr/local/lib/python2.7/dist-packages/appdirs-1.4.2.dist-info/METADATA'
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment