Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
---------------------------------------------------------------------------
ValueError Traceback (most recent call last)
<ipython-input-1-efe73691b2de> in <module>()
2 matplotlib.use("Qt4Agg")
3
----> 4 import hyperspy.api as hs
5
6 get_ipython().magic(u'matplotlib')
/Users/thomas/anaconda/lib/python2.7/site-packages/hyperspy/api.py in <module>()
57
58 from hyperspy.Release import version as __version__
---> 59 from hyperspy import signals
60 from hyperspy.io import load
61 from hyperspy.defaults_parser import preferences
/Users/thomas/anaconda/lib/python2.7/site-packages/hyperspy/signals.py in <module>()
37 # -*- coding: utf-8 -*-
38
---> 39 from hyperspy._signals.spectrum import Spectrum
40 from hyperspy._signals.image import Image
41 from hyperspy._signals.eels import EELSSpectrum
/Users/thomas/anaconda/lib/python2.7/site-packages/hyperspy/_signals/spectrum.py in <module>()
23
24 from hyperspy.exceptions import DataDimensionError
---> 25 from hyperspy.signal import Signal
26 from hyperspy.gui.egerton_quantification import SpikesRemoval
27
/Users/thomas/anaconda/lib/python2.7/site-packages/hyperspy/signal.py in <module>()
43 from hyperspy.axes import AxesManager
44 from hyperspy import io
---> 45 from hyperspy.drawing import mpl_hie, mpl_hse, mpl_he
46 from hyperspy.learn.mva import MVA, LearningResults
47 import hyperspy.misc.utils
/Users/thomas/anaconda/lib/python2.7/site-packages/hyperspy/drawing/mpl_hie.py in <module>()
17 # along with HyperSpy. If not, see <http://www.gnu.org/licenses/>.
18
---> 19 from hyperspy.drawing import image, utils
20 from hyperspy.drawing.mpl_he import MPL_HyperExplorer
21
/Users/thomas/anaconda/lib/python2.7/site-packages/hyperspy/drawing/image.py in <module>()
28 from hyperspy.drawing import widgets
29 from hyperspy.drawing import utils
---> 30 from hyperspy.gui.tools import ImageContrastEditor
31 from hyperspy.misc import math_tools
32 from hyperspy.misc import rgb_tools
/Users/thomas/anaconda/lib/python2.7/site-packages/hyperspy/gui/tools.py in <module>()
21 import matplotlib.pyplot as plt
22 import traits.api as t
---> 23 import traitsui.api as tu
24 from traitsui.menu import (OKButton, CancelButton, OKCancelButtons)
25
/Users/thomas/anaconda/lib/python2.7/site-packages/traitsui/api.py in <module>()
34
35 try:
---> 36 from .editors.api import ArrayEditor
37 except ImportError:
38 # ArrayEditor depends on numpy, so ignore if numpy is not present.
/Users/thomas/anaconda/lib/python2.7/site-packages/traitsui/editors/__init__.py in <module>()
21
22 try:
---> 23 from .api import ArrayEditor
24 except ImportError:
25 pass
/Users/thomas/anaconda/lib/python2.7/site-packages/traitsui/editors/api.py in <module>()
22 from .button_editor import ButtonEditor
23 from .check_list_editor import CheckListEditor
---> 24 from .code_editor import CodeEditor
25 from .color_editor import ColorEditor
26 from .compound_editor import CompoundEditor
/Users/thomas/anaconda/lib/python2.7/site-packages/traitsui/editors/code_editor.py in <module>()
34 #-------------------------------------------------------------------------------
35
---> 36 class ToolkitEditorFactory ( EditorFactory ):
37 """ Editor factory for code editors.
38 """
/Users/thomas/anaconda/lib/python2.7/site-packages/traitsui/editors/code_editor.py in ToolkitEditorFactory()
46
47 # Background color for marking lines
---> 48 mark_color = Color( 0xECE9D8 )
49
50 # Object trait containing the currently selected line (optional)
/Users/thomas/anaconda/lib/python2.7/site-packages/traits/traits.pyc in __call__(self, *args, **metadata)
487
488 def __call__ ( self, *args, **metadata ):
--> 489 return self.maker_function( *args, **metadata )
490
491 class TraitImportError ( TraitFactory ):
/Users/thomas/anaconda/lib/python2.7/site-packages/traits/traits.pyc in Color(*args, **metadata)
1201 from traitsui.toolkit_traits import ColorTrait
1202
-> 1203 return ColorTrait( *args, **metadata )
1204
1205 Color = TraitFactory( Color )
/Users/thomas/anaconda/lib/python2.7/site-packages/traitsui/toolkit_traits.pyc in ColorTrait(*args, **traits)
5
6 def ColorTrait ( *args, **traits ):
----> 7 return toolkit().color_trait( *args, **traits )
8
9 def RGBColorTrait ( *args, **traits ):
/Users/thomas/anaconda/lib/python2.7/site-packages/traitsui/toolkit.pyc in toolkit(*toolkits)
107 if ETSConfig.toolkit:
108 # If a toolkit has already been set for ETSConfig, then use it:
--> 109 _toolkit = _import_toolkit(ETSConfig.toolkit)
110 return _toolkit
111 else:
/Users/thomas/anaconda/lib/python2.7/site-packages/traitsui/toolkit.pyc in _import_toolkit(name)
49
50 def _import_toolkit ( name ):
---> 51 return __import__( name, globals=globals(), level=1 ).toolkit
52
53
/Users/thomas/anaconda/lib/python2.7/site-packages/traitsui/qt4/__init__.py in <module>()
16 # import pyface.qt before anything else is done so the sipapi
17 # can be set correctly if needed
---> 18 import pyface.qt
19
20 #----------------------------------------------------------------------------
/Users/thomas/anaconda/lib/python2.7/site-packages/pyface/qt/__init__.py in <module>()
38
39 elif qt_api == 'pyqt':
---> 40 prepare_pyqt4()
41
42 elif qt_api != 'pyside':
/Users/thomas/anaconda/lib/python2.7/site-packages/pyface/qt/__init__.py in prepare_pyqt4()
15 # Set PySide compatible APIs.
16 import sip
---> 17 sip.setapi('QDate', 2)
18 sip.setapi('QDateTime', 2)
19 sip.setapi('QString', 2)
ValueError: API 'QDate' has already been set to version 1
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.