Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Error with a fresh single-user 64-bit install of Hyperspy 0.8.4
>>> %matplotlib
RuntimeError Traceback (most recent call last)
<ipython-input-3-fc39d5fd4eba> in <module>()
----> 1 get_ipython().magic('matplotlib')
C:\Users\EMGroup\AppData\Local\HyperSpy WinPython Bundle 0.8.4\python-3.4.4.amd64\lib\site-packages\IPython\core\interactiveshell.py in magic(self, arg_s)
2161 magic_name, _, magic_arg_s = arg_s.partition(' ')
2162 magic_name = magic_name.lstrip(prefilter.ESC_MAGIC)
-> 2163 return self.run_line_magic(magic_name, magic_arg_s)
2164
2165 #-------------------------------------------------------------------------
C:\Users\EMGroup\AppData\Local\HyperSpy WinPython Bundle 0.8.4\python-3.4.4.amd64\lib\site-packages\IPython\core\interactiveshell.py in run_line_magic(self, magic_name, line)
2082 kwargs['local_ns'] = sys._getframe(stack_depth).f_locals
2083 with self.builtin_trap:
-> 2084 result = fn(*args,**kwargs)
2085 return result
2086
<decorator-gen-107> in matplotlib(self, line)
C:\Users\EMGroup\AppData\Local\HyperSpy WinPython Bundle 0.8.4\python-3.4.4.amd64\lib\site-packages\IPython\core\magic.py in <lambda>(f, *a, **k)
191 # but it's overkill for just that one bit of state.
192 def magic_deco(arg):
--> 193 call = lambda f, *a, **k: f(*a, **k)
194
195 if callable(arg):
C:\Users\EMGroup\AppData\Local\HyperSpy WinPython Bundle 0.8.4\python-3.4.4.amd64\lib\site-packages\IPython\core\magics\pylab.py in matplotlib(self, line)
98 print("Available matplotlib backends: %s" % backends_list)
99 else:
--> 100 gui, backend = self.shell.enable_matplotlib(args.gui)
101 self._show_matplotlib_backend(args.gui, backend)
102
C:\Users\EMGroup\AppData\Local\HyperSpy WinPython Bundle 0.8.4\python-3.4.4.amd64\lib\site-packages\IPython\core\interactiveshell.py in enable_matplotlib(self, gui)
2954 # Now we must activate the gui pylab wants to use, and fix %run to take
2955 # plot updates into account
-> 2956 self.enable_gui(gui)
2957 self.magics_manager.registry['ExecutionMagics'].default_runner = \
2958 pt.mpl_runner(self.safe_execfile)
C:\Users\EMGroup\AppData\Local\HyperSpy WinPython Bundle 0.8.4\python-3.4.4.amd64\lib\site-packages\ipykernel\zmqshell.py in enable_gui(gui)
380 from .eventloops import enable_gui as real_enable_gui
381 try:
--> 382 real_enable_gui(gui)
383 except ValueError as e:
384 raise UsageError("%s" % e)
C:\Users\EMGroup\AppData\Local\HyperSpy WinPython Bundle 0.8.4\python-3.4.4.amd64\lib\site-packages\ipykernel\eventloops.py in enable_gui(gui, kernel)
270 loop = loop_map[gui]
271 if loop and kernel.eventloop is not None and kernel.eventloop is not loop:
--> 272 raise RuntimeError("Cannot activate multiple GUI eventloops")
273 kernel.eventloop = loop
RuntimeError: Cannot activate multiple GUI eventloops
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment