Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
```
Fetching rmagick 2.16.0
Installing rmagick 2.16.0 with native extensions
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.
current directory: /Users/s/.gem/ruby/2.5.1/gems/rmagick-2.16.0/ext/RMagick
/Users/s/.rubies/ruby-2.5.1/bin/ruby -r ./siteconf20180624-31720-1jgmacc.rb extconf.rb
checking for clang... yes
checking for Magick-config... yes
checking for outdated ImageMagick version (<= 6.4.9)... no
checking for presence of MagickWand API (ImageMagick version >= 6.9.0)... no
/usr/local/opt/imagemagick@6/bin/MagickWand-config: line 41:
/usr/local/opt/pkg-config/bin/pkg-config: No such file or directory
/usr/local/opt/imagemagick@6/bin/MagickWand-config: line 47:
/usr/local/opt/pkg-config/bin/pkg-config: No such file or directory
/usr/local/opt/imagemagick@6/bin/MagickWand-config: line 50:
/usr/local/opt/pkg-config/bin/pkg-config: No such file or directory
/usr/local/opt/imagemagick@6/bin/MagickWand-config: line 53:
/usr/local/opt/pkg-config/bin/pkg-config: No such file or directory
checking for Ruby version >= 1.8.5... yes
/usr/local/opt/imagemagick@6/bin/Magick-config: line 53:
/usr/local/opt/pkg-config/bin/pkg-config: No such file or directory
Can't install RMagick 2.16.0. Can't find the ImageMagick library or one of the dependent
libraries. Check the mkmf.log file for more detailed information.
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers. Check the mkmf.log file for more details. You may
need configuration options.
Provided configuration options:
--with-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=/Users/s/.rubies/ruby-2.5.1/bin/$(RUBY_BASE_NAME)
To see why this extension failed to compile, please check the mkmf.log which can be found here:
/Users/s/.gem/ruby/2.5.1/extensions/x86_64-darwin-17/2.5.0-static/rmagick-2.16.0/mkmf.log
extconf failed, exit code 1
Gem files will remain installed in /Users/s/.gem/ruby/2.5.1/gems/rmagick-2.16.0 for inspection.
Results logged to
/Users/s/.gem/ruby/2.5.1/extensions/x86_64-darwin-17/2.5.0-static/rmagick-2.16.0/gem_make.out
An error occurred while installing rmagick (2.16.0), and Bundler cannot continue.
Make sure that `gem install rmagick -v '2.16.0' --source 'https://rubygems.org/'` succeeds
before bundling.
In Gemfile:
rmagick
```
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.