Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
In a fresh Rails 5.2 app, `rails credentials:edit` works as advertised. In my Rails 5.2 app, something has been changed and `rails credentials:edit` doesn't work. It gives the error below. I can't find what change caused this.
activesupport-5.2.2/lib/active_support/message_encryptor.rb:206:
in `rescue in _decrypt':
ActiveSupport::MessageEncryptor::InvalidMessage (ActiveSupport::MessageEncryptor::InvalidMessage)
1: from activesupport-5.2.2/lib/active_support/message_encryptor.rb:183:in `_decrypt'
2: from activesupport-5.2.2/lib/active_support/message_encryptor.rb:157:in `decrypt_and_verify'
3: from activesupport-5.2.2/lib/active_support/messages/rotator.rb:21:in `decrypt_and_verify'
4: from activesupport-5.2.2/lib/active_support/encrypted_file.rb:79:in `decrypt'
5: from activesupport-5.2.2/lib/active_support/encrypted_file.rb:42:in `read'
6: from activesupport-5.2.2/lib/active_support/encrypted_configuration.rb:21:in `read'
7: from activesupport-5.2.2/lib/active_support/encrypted_file.rb:54:in `change'
8: from railties-5.2.2/lib/rails/commands/credentials/credentials_command.rb:50:in `change_credentials_in_system_editor'
9: from railties-5.2.2/lib/rails/commands/credentials/credentials_command.rb:27:in `block in edit'
10: from railties-5.2.2/lib/rails/command/helpers/editor.rb:26:in `catch_editing_exceptions'
11: from railties-5.2.2/lib/rails/commands/credentials/credentials_command.rb:26:in `edit'
12: from thor-0.20.3/lib/thor/command.rb:27:in `run'
13: from thor-0.20.3/lib/thor/invocation.rb:126:in `invoke_command'
14: from thor-0.20.3/lib/thor.rb:387:in `dispatch'
15: from railties-5.2.2/lib/rails/command/base.rb:65:in `perform'
16: from railties-5.2.2/lib/rails/command.rb:46:in `invoke'
17: from railties-5.2.2/lib/rails/commands.rb:18:in `<main>'
18: from bootsnap-1.4.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
19: from bootsnap-1.4.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
20: from bootsnap-1.4.1/lib/bootsnap/load_path_cache/loaded_features_index.rb:83:in `register'
21: from bootsnap-1.4.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
22: from bootsnap-1.4.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
23: from activesupport-5.2.2/lib/active_support/dependencies.rb:291:in `block in require'
24: from activesupport-5.2.2/lib/active_support/dependencies.rb:257:in `load_dependency'
25: from activesupport-5.2.2/lib/active_support/dependencies.rb:291:in `require'
26: from bin/rails:4:in `<main>'
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.