Skip to content

Embed URL

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
cpan[1]> test JBERGER/Alien-Base-0.000_020.tar.gz
Reading 'C:\Perl\cpan\Metadata'
Database was generated on Mon, 02 Jul 2012 19:58:03 GMT
Running make for J/JB/JBERGER/Alien-Base-0.000_020.tar.gz
Fetching with LWP:
http://cpan.cpantesters.org/authors/id/J/JB/JBERGER/Alien-Base-0.000_020.tar.gz
Fetching with LWP:
http://cpan.cpantesters.org/authors/id/J/JB/JBERGER/CHECKSUMS
Checksum for C:\Perl\cpan\sources\authors\id\J\JB\JBERGER\Alien-Base-0.000_020.tar.gz ok
Scanning cache C:\Perl/cpan/build for sizes
.........................................................................---DONE
DEL(1/4): C:\Perl\cpan\build\Catalyst-Action-REST-1.04-FZqrKk
DEL(2/4): C:\Perl\cpan\build\Catalyst-Action-REST-1.04-FZqrKk.yml
DEL(3/4): C:\Perl\cpan\build\Catalyst-Controller-ActionRole-0.15-0v0UfN
DEL(4/4): C:\Perl\cpan\build\Catalyst-Controller-ActionRole-0.15-0v0UfN.yml
CPAN.pm: Building J/JB/JBERGER/Alien-Base-0.000_020.tar.gz
Checking prerequisites...
recommends:
* ExtUtils::LibBuilder is not installed
ERRORS/WARNINGS FOUND IN PREREQUISITES. You may wish to install the versions
of the modules indicated above before proceeding with this installation
Created MYMETA.yml and MYMETA.json
Creating new 'Build' script for 'Alien-Base' version '0.000_020'
(C:\Perl\bin\perl.exe Build.PL --installdirs=site exited with 0)
CPAN::Reporter: Build.PL result is 'pass', No errors.
Building Alien-Base
(C:\Perl\bin\perl.exe ./Build exited with 0)
CPAN::Reporter: Build result is 'pass', No errors.
JBERGER/Alien-Base-0.000_020.tar.gz
C:\Perl\bin\perl.exe ./Build -- OK
Running Build test
t\builder.t .............. ok
t\cabinet.t .............. ok
t\file.t ................. ok
t\find_lib.t ............. ok
t\http.t ................. ok
t\interpolate.t .......... ok
t\local_repo.t ........... ok
t\pkgconfig.t ............ ok
t\repository.t ........... ok
t\utils.t ................ ok
t\validation.t ........... ok
'pkg-config' is not recognized as an internal or external command,
operable program or batch file.
t\version.t .............. ok
'pkg-config' is not recognized as an internal or external command,
operable program or batch file.
t\yy-system_installed.t .. skipped: Cannot use pkg-config: 256
Can't locate ExtUtils/LibBuilder.pm in @INC (@INC contains: C:\Perl\cpan\build\Alien-Base-0.000_020-eZ1z7J\blib\lib C:Perl\cpan\build\Alien-Base-0.000_020-eZ1z7J\blib\arch C:/Perl/site/lib/MSWin32-x86-multi-thread C:/Perl/site/lib C:/Perl/lib .) at t\zz-example.t line 8.
BEGIN failed--compilation aborted at t\zz-example.t line 8.
t\zz-example.t ...........
Dubious, test returned 2 (wstat 512, 0x200)
No subtests run
Test Summary Report
-------------------
t\zz-example.t (Wstat: 512 Tests: 0 Failed: 0)
Non-zero exit status: 2
Parse errors: No plan found in TAP output
Files=14, Tests=80, 6 wallclock secs ( 0.06 usr + 0.03 sys = 0.09 CPU)
Result: FAIL
Failed 1/14 test programs. 0/80 subtests failed.
(C:\Perl\bin\perl.exe ./Build test exited with 512)
CPAN::Reporter: Test result is 'fail', One or more tests failed.
CPAN::Reporter: preparing a CPAN Testers report for Alien-Base-0.000_020
CPAN::Reporter: sending test report with 'fail' via Metabase
JBERGER/Alien-Base-0.000_020.tar.gz
C:\Perl\bin\perl.exe ./Build test -- NOT OK
//hint// to see the cpan-testers results for installing this module, try:
reports JBERGER/Alien-Base-0.000_020.tar.gz
Failed during this command:
JBERGER/Alien-Base-0.000_020.tar.gz : make_test NO
cpan[2]> install ExtUtils::LibBuilder
Running install for module 'ExtUtils::LibBuilder'
Running make for A/AM/AMBS/ExtUtils/ExtUtils-LibBuilder-0.04.tar.gz
Fetching with LWP:
http://cpan.cpantesters.org/authors/id/A/AM/AMBS/ExtUtils/ExtUtils-LibBuilder-0.04.tar.gz
Fetching with LWP:
http://cpan.cpantesters.org/authors/id/A/AM/AMBS/ExtUtils/CHECKSUMS
Checksum for C:\Perl\cpan\sources\authors\id\A\AM\AMBS\ExtUtils\ExtUtils-LibBuilder-0.04.tar.gz ok
CPAN.pm: Building A/AM/AMBS/ExtUtils/ExtUtils-LibBuilder-0.04.tar.gz
Created MYMETA.yml and MYMETA.json
Creating new 'Build' script for 'ExtUtils-LibBuilder' version '0.04'
(C:\Perl\bin\perl.exe Build.PL --installdirs=site exited with 0)
CPAN::Reporter: Build.PL result is 'pass', No errors.
Building ExtUtils-LibBuilder
(C:\Perl\bin\perl.exe ./Build exited with 0)
CPAN::Reporter: Build result is 'pass', No errors.
AMBS/ExtUtils/ExtUtils-LibBuilder-0.04.tar.gz
C:\Perl\bin\perl.exe ./Build -- OK
Running Build test
# Testing ExtUtils::LibBuilder 0.04, Perl 5.012004, C:\Perl\bin\perl.exe
t\00-load.t ....... ok
Use of uninitialized value $P in concatenation (.) or string at t\01-simple.t line 77, <DATA> line 226.
t\01-simple.t ..... ok
t\manifest.t ...... skipped: Author tests not required for installation
t\pod-coverage.t .. ok
t\pod.t ........... ok
All tests successful.
Files=5, Tests=10, 2 wallclock secs ( 0.05 usr + 0.00 sys = 0.05 CPU)
Result: PASS
(C:\Perl\bin\perl.exe ./Build test exited with 0)
CPAN::Reporter: Test result is 'pass', All tests successful.
CPAN::Reporter: preparing a CPAN Testers report for ExtUtils-LibBuilder-0.04
CPAN::Reporter: sending test report with 'pass' via Metabase
AMBS/ExtUtils/ExtUtils-LibBuilder-0.04.tar.gz
C:\Perl\bin\perl.exe ./Build test -- OK
Running Build install
Building ExtUtils-LibBuilder
Installing C:\Perl\site\lib\ExtUtils\LibBuilder.pm
Installing C:\Perl\man\man3\ExtUtils.LibBuilder.3
Installing C:\Perl\html\site\lib\ExtUtils\LibBuilder.html
Building ActivePerl Table of Contents
For ActivePerl's PPM: touch 'C:\Perl\lib\perllocal.pod'
AMBS/ExtUtils/ExtUtils-LibBuilder-0.04.tar.gz
C:\Perl\bin\perl.exe ./Build install -- OK
cpan[3]> test JBERGER/Alien-Base-0.000_020.tar.gz
Running Build for J/JB/JBERGER/Alien-Base-0.000_020.tar.gz
Has already been unwrapped into directory C:\Perl\cpan\build\Alien-Base-0.000_020-eZ1z7J
Has already been made
Running Build test
t\builder.t .............. ok
t\cabinet.t .............. ok
t\file.t ................. ok
t\find_lib.t ............. ok
t\http.t ................. ok
t\interpolate.t .......... ok
t\local_repo.t ........... ok
t\pkgconfig.t ............ ok
t\repository.t ........... ok
t\utils.t ................ ok
t\validation.t ........... ok
'pkg-config' is not recognized as an internal or external command,
operable program or batch file.
t\version.t .............. ok
'pkg-config' is not recognized as an internal or external command,
operable program or batch file.
t\yy-system_installed.t .. skipped: Cannot use pkg-config: 256
cannot unlink file for blib\arch\auto\Ford\Prefect\Prefect.dll: Permission denied at C:/Perl/site/lib/Module/Build/Base.pm line 5286.
Could not clean up after tests (Ford::Prefect), this isn't a big problem at t\zz-example.t line 94.
cannot unlink file for C:\Perl\cpan\build\Alien-Base-0.000_020-eZ1z7J\examples\Alien-DontPanic\_install\lib\libdontpanic.dll: Permission denied at C:/Perl/site/lib/Module/Build/Base.pm line 5286.
cannot remove directory for C:\Perl\cpan\build\Alien-Base-0.000_020-eZ1z7J\examples\Alien-DontPanic\_install\lib: Directory not empty at C:/Perl/site/lib/Module/Build/Base.pm line5286.
cannot remove directory for C:\Perl\cpan\build\Alien-Base-0.000_020-eZ1z7J\examples\Alien-DontPanic\_install: Directory not empty at C:/Perl/site/lib/Module/Build/Base.pm line 5286.
Could not clean up after tests (Alien::Base), this isn't a big problem at t\zz-example.t line 101.
t\zz-example.t ........... ok
All tests successful.
Files=14, Tests=94, 16 wallclock secs ( 0.11 usr + 0.03 sys = 0.14 CPU)
Result: PASS
(C:\Perl\bin\perl.exe ./Build test exited with 0)
CPAN::Reporter: Test result is 'pass', All tests successful.
CPAN::Reporter: preparing a CPAN Testers report for Alien-Base-0.000_020
CPAN::Reporter: sending test report with 'pass' via Metabase
JBERGER/Alien-Base-0.000_020.tar.gz
C:\Perl\bin\perl.exe ./Build test -- OK
cpan[4]>
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.