Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Install hipChat on Ubuntu 14.04
sudo su
echo "deb http://downloads.hipchat.com/linux/apt stable main" > \ /etc/apt/sources.list.d/atlassian-hipchat.list
wget -O - https://www.hipchat.com/keys/hipchat-linux.key | apt-key add -
apt-get update
apt-get install hipchat
@rajesh38
Copy link

rajesh38 commented Feb 15, 2015

"apt-get install hipchat"

didn't run

saying:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package hipchat

@rajesh38
Copy link

rajesh38 commented Feb 15, 2015

It's from the official site of hipchat

sudo su
echo "deb http://downloads.hipchat.com/linux/apt stable main" >
/etc/apt/sources.list.d/atlassian-hipchat.list
wget -O - https://www.hipchat.com/keys/hipchat-linux.key | apt-key add -
apt-get update
apt-get install hipchat

Copy link

ghost commented Feb 25, 2015

E: Unable to locate package hipchat

I get the same thing on 14.10

@grubernaut
Copy link

grubernaut commented Mar 5, 2015

Line 2 should be:

echo "deb http://downloads.hipchat.com/linux/apt stable main" > /etc/apt/sources.list.d/atlassian-hipchat.list

And it will work perfectly. You only need the \ character when splitting multiple lines.

@abhinavkumar940
Copy link

abhinavkumar940 commented Mar 13, 2015

I can confirm that it works like a breeze. I just tried it on Ubuntu 12 and it's up and running!

@alexandru-calinoiu
Copy link

alexandru-calinoiu commented Apr 14, 2015

I get

Cannot write to ‘-’ (Success).

When running:

 wget -O - https://www.hipchat.com/keys/hipchat-linux.key | apt-key add -

@saravananNV
Copy link

saravananNV commented Jul 7, 2015

how to launch hipchat via terminal

@molavec
Copy link

molavec commented Dec 23, 2015

I have same issue than @alexandru-calinoiu. I activated root user:

http://askubuntu.com/questions/44418/how-to-enable-root-login

Any another way to avoid activate it?

@canh-nguyen-cr
Copy link

canh-nguyen-cr commented Apr 6, 2016

Following this instruction, I installed it successfully on Ubuntu 14.04:
https://www.hipchat.com/downloads
sudo sh -c 'echo "deb https://atlassian.artifactoryonline.com/atlassian/hipchat-apt-client $(lsb_release -c -s) main" > /etc/apt/sources.list.d/atlassian-hipchat4.list'
wget -O - https://atlassian.artifactoryonline.com/atlassian/api/gpg/key/public | sudo apt-key add -
sudo apt-get update
sudo apt-get install hipchat4

@jasonzhang2022
Copy link

jasonzhang2022 commented Apr 22, 2016

Failed with this error message
W: Failed to fetch https://atlassian.artifactoryonline.com/atlassian/hipchat-apt-client/dists/precise/main/binary-amd64/Packages

W: Failed to fetch https://atlassian.artifactoryonline.com/atlassian/hipchat-apt-client/dists/precise/main/binary-i386/Packages

E: Some index files failed to download. They have been ignored, or old ones used instead.

The URL is not correct!

@wlk
Copy link

wlk commented Jan 12, 2017

Official instructions are here: https://www.hipchat.com/downloads

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment