Skip to content

Instantly share code, notes, and snippets.

Takeshi Morikawa morika-t

  • NTT TechnoCross Corporation
  • Tokyo, Japan
Block or report user

Report or block morika-t

Hide content and notifications from this user.

Learn more about blocking users

Contact Support about this user’s behavior.

Learn more about reporting abuse

Report abuse
View GitHub Profile
View about_docker-cf-jumpbox.md

docker-cf-jumpboxについて

Cloud Foundry Advent Calendar 2017の2日目の記事です。

はじめに、ポエムを少々

こんにちは。

私も、会社で私が所属しているチームも、貧乏です。会社自体はリッチかもしれませんが。

View tmux_cygwin.md

Steps to install tmux in Cygwin

Install required Cygwin packages

  1. run Cygwin setup.exe
  2. install these packages that are not installed by default: automake, gcc, git and pkg-config

Install libevent

  1. browse http://libevent.org
  2. download libevent-2.0.21-stable.tar.gz
View testing minio heal feature.md

Install Setup [running on ubuntu 16.04]

1. Install go 1.7.5

sudo apt-get install git 
wget https://storage.googleapis.com/golang/go1.7.5.linux-amd64.tar.gz
tar -C ${HOME} -xzf go1.7.5.linux-amd64.tar.gz

Add the following exports to your ~/.bashrc.

@morika-t
morika-t / concoruse-fly-command-bash-completion.md
Created Apr 26, 2017
Concourseのflyコマンド(cli)のbash-completionファイル
View concoruse-fly-command-bash-completion.md
# bash completion for Concourse CLI

_fly-cli() {
    # All arguments except the first one
    args=("${COMP_WORDS[@]:1:$COMP_CWORD}")
    # Only split on newlines
    local IFS=$'\n'
    # Call completion (note that the first element of COMP_WORDS is
    # the executable itself)
View nats.sh
#!/bin/bash
# Assumes using nats CLI from https://github.com/soutenniza/nats/releases
DIR=$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )
cd $DIR/..
bosh_target=$(cat .bosh_config | yaml2json | jq -r ".target")
manifest=$(cat .bosh_config | yaml2json | jq -r ".deployment[\"$bosh_target\"]")
mbus=$(cat $manifest | yaml2json | jq -r '.properties.nats | "nats://\(.user):\(.password)@\(.address):\(.port)"')
View locale_diff.rb
# Run: curl https://gist.github.com/raw/719970/locale_diff.rb | ruby - en fi
require 'rubygems'
require 'yaml'
l1 = ARGV[0]
l2 = ARGV[1]
first = YAML.load_file(l1 + ".yml")
second = YAML.load_file(l2 + ".yml")
def diff(root, compared, structure = [])
View example.rb
require 'active_support'
# in some cases i've found JSON.pretty_generate doesn't output properly
# when combined with ActiveSupport::OrderedHash without json/pure
# require 'json/pure'
def returning(value)
yield(value)
value
end
View changelog_en.md

ChangeLog を支える英語

ChangeLog を書く際によく使われる英語をまとめました。

ほとんど引用です。

基本形

View _readme.md

Having trouble installing the latest stable version of tmux?

I know, official package for your OS/distro is outdated and you just want the newest version of tmux.

Well, this script should save you some time with that.

Prerequisities

  • gcc
@morika-t
morika-t / s3.rb
Last active Aug 29, 2015 — forked from bouzuya/s3.rb
View s3.rb
require 'rubygems'
require 'bundler/setup'
require 'aws-sdk'
# NOTE: require ENV[...]
# export AWS_ACCESS_KEY_ID='...'
# export AWS_SECRET_ACCESS_KEY='...'
# export AWS_REGION='ap-northeast-1'
s3 = AWS::S3.new
You can’t perform that action at this time.