Skip to content

Instantly share code, notes, and snippets.

View gist:7ac7377b5a88872b0343
(VE)[qwcode@qwcode tmp]$ pip --version
pip 6.1.1 from /tmp/VE/lib/python2.7/site-packages (python 2.7)
(VE)[qwcode@qwcode tmp]$ pip install -vv --no-clean peppercorn
Collecting peppercorn
Getting page https://pypi.python.org/simple/peppercorn/
1 location(s) to search for versions of peppercorn:
* https://pypi.python.org/simple/peppercorn/
Getting page https://pypi.python.org/simple/peppercorn/
Analyzing links from page https://pypi.python.org/simple/peppercorn/
Found link https://pypi.python.org/packages/source/p/peppercorn/peppercorn-0.1.tar.gz#md5=e130ffecc953a1f1ae5d1a25c10f85f3 (from https://pypi.python.org/simple/peppercorn/), version: 0.1
View gist:f7b1b7513df64fb36f15
(VE)[qwcode@qwcode tmp]$ pip install peppercorn==0.2
Collecting peppercorn==0.2
Downloading peppercorn-0.2.tar.gz
Installing collected packages: peppercorn
Running setup.py install for peppercorn
Successfully installed peppercorn-0.2
(VE)[qwcode@qwcode tmp]$ pip install deform
Collecting deform
Using cached deform-0.9.9.tar.gz
Collecting Chameleon>=2.5.1 (from deform)
View gist:ec403cba59d15a8e7a1f
* CFPropertyList (2.2.8)
* addressable (2.3.6)
* archive-tar-minitar (0.5.2)
* autoparse (0.3.3)
* aws-sdk (1.42.0)
* backports (3.6.4)
* beaker (1.20.1)
* beaker-rspec (3.0.0)
* blimpy (0.6.7)
* builder (3.2.2)
View gist:5bb4066a4872ef0220e6
bundle exec gem list
addressable (2.3.6)
archive-tar-minitar (0.5.2)
autoparse (0.3.3)
aws-sdk (1.42.0)
backports (3.6.4)
beaker (1.20.1)
beaker-rspec (3.0.0)
blimpy (0.6.7)
View gist:100f8c0062f9ff52e97e
this line in spec_helper_acceptance.rb
puppet_module_install(:source => proj_root, :module_name => 'selenium')
translates to this in beaker output:
centos-65-x64 executed in 0.08 seconds
localhost $ scp /home/qwcode/p/cox/puppet-selenium centos-65-x64:/etc/puppet/modules/selenium {:ignore => [".bundle", ".git", ".idea", ".vagrant", ".vendor", "acceptance", "spec", "tests", "log", ".", ".."]}
Exited:
View gist:2e8c3bdd42aa8d97f4ca
Error: undefined method `issues_url' for #<Puppet::ModuleTool::Metadata:0x00000001bbe8c8>
Error: Try 'puppet help module generate' for usage
View gist:533ff5f6e4b5840f7af2
(medley_behave)-bash-4.1$ medley_behave /vagrant/medley_behave/features/story_features/story_highlights.feature
Feature: As a producer, I need the ability to add story highlights to a story # features/story_featu res/story_highlights.feature:3
@story @story_highlights @jp2
Scenario: Create and capture the story highlights content to a story. # features/story_features/story_highlights.feature:7
Given I am logged on to the JP2 site admin # features/steps/admin.py:56 33.590s
View gist:e57924ad81dad7c1d770
amazon-ebs: ---> Package bash.x86_64 0:4.1.2-14.el6 will be updated
amazon-ebs: ---> Package bash.x86_64 0:4.1.2-15.el6_5.2 will be an update
amazon-ebs: ---> Package ca-certificates.noarch 0:2010.63-3.el6_1.5 will be updated
amazon-ebs: ---> Package ca-certificates.noarch 0:2014.1.98-65.0.el6_5 will be an update
amazon-ebs: ---> Package centos-release.x86_64 0:6-4.el6.centos.10 will be updated
amazon-ebs: ---> Package centos-release.x86_64 0:6-5.el6.centos.11.2 will be an update
amazon-ebs: ---> Package chkconfig.x86_64 0:1.3.49.3-2.el6 will be updated
amazon-ebs: ---> Package chkconfig.x86_64 0:1.3.49.3-2.el6_4.1 will be an update
amazon-ebs: ---> Package coreutils.x86_64 0:8.4-19.el6_4.2 will be updated
amazon-ebs: ---> Package coreutils.x86_64 0:8.4-31.el6_5.2 will be an update
@qwcode
qwcode / gist:b15faeea2f2a2617294f
Last active Aug 29, 2015
pip --no-clean --build (in a virtual environment v1.5.6)
View gist:b15faeea2f2a2617294f
(VE)qwcode@qwcode:/tmp$ pip install peppercorn
Downloading/unpacking peppercorn
Downloading peppercorn-0.4.tar.gz
Running setup.py (path:/tmp/VE/build/peppercorn/setup.py) egg_info for package peppercorn
Installing collected packages: peppercorn
Running setup.py install for peppercorn
Successfully installed peppercorn
Cleaning up...
View gist:569afafab50e35bdd0d1
(VE)qwcode@qwcode:/tmp$ VE/bin/pip install pip==1.5.5
Downloading/unpacking pip==1.5.5
Downloading pip-1.5.5-py2.py3-none-any.whl (1.2MB): 1.2MB downloaded
Installing collected packages: pip
Found existing installation: pip 1.5.6
Uninstalling pip:
Successfully uninstalled pip
Successfully installed pip
Cleaning up...
(VE)qwcode@qwcode:/tmp$ VE/bin/pip install --allow-external ctypes --allow-unverified ctypes ctypes
You can’t perform that action at this time.